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1.0  Introduction & General Description 
 
1.1 Scope of this Manual 
 
 This manual provides complete instructions and 
reference information for using the Q-Tracker™ 
Windows™ data analysis software in connection with the 
Q-Tracker temporary sewer flow monitor. In the manual, 
this software will sometimes be referred to simply as the 
“program”. 
 
 If you are already prepared to begin, you do not 
have to read any further here. Go directly to Section 2 for 
a summary of procedures, and refer to subsequent sections 
as necessary for further details. 
 
 The Q-Tracker program runs only under 
Microsoft® Windows™. Therefore in order to understand 
this manual and use the program, you must be familiar 
with Windows and the computer involved. This manual 
does not provide any instructions in using Windows or 
computers. 
 
 There is another user’s manual which provides 
instructions for using the Q-Tracker flow monitor. That 
manual also explains another program, one which runs 
under DOS™ without Windows. No instructions are 
provided in this manual on the flow monitor or Q-Tracker 
DOS, other than a brief introduction. 
 
 The Q-Tracker program is designed to be mostly 
self-explanatory. If you are familiar with the Q-Tracker 
and have used other Windows-based programs, you could 
teach yourself how to use this program simply by 
experimenting with it. This manual is provided to ease the 
learning process, help avoid troublesome mistakes such as 
accidentally erasing or changing valuable data files, and 
help you obtain full benefit of all the program’s features. 
 
 Like other software packages, Q-Tracker is 
improved from time to time, and upgraded versions are 
issued. This manual was written for Version 1.08 of the 
program. However, it is intended to apply to a number of 
future versions of the program. When necessary, Badger 
Meter issues release notes explaining program changes. 
 
1.2 General Description of the Q-Tracker Software 
 The Main purpose of the program is to help 
engineers analyze and interpret flow data collected by Q-
Tracker monitors. These periodic measurements are for a 
survey of the hydraulic performance of an existing 
underground sewer network. For such a survey, a number 
of monitors are installed at carefully selected points. They 
accumulate flow measurement data over a period of weeks 
or months. The flow data is retrieved from the monitors 
periodically, perhaps weekly, by operators equipped with 
small portable computers. An operator temporarily 
connects a computer to a flow monitor with a cable 
between  
 

 
 
serial data ports. The computer is also used for setting up 
and calibrating the monitor. For these purposes of data 
retrieval, setup, and calibration, Badger provides DOS 
software used in the portable computers. 
 
 Q-Tracker software, in turn, is intended to run on a 
desktop computer in an engineering office. Data collected 
by the portable computers are transferred to the desktop 
computer via diskettes or other means. There, the data is 
analyzed in connection with the hydraulic survey project, 
using the Q-Tracker software explained in this manual. 
 
 The program provides three main analysis tools: 
 
 A. Spreadsheets  in which data from one or more 

stations can be manipulated, 
 B. Colored graphs of several types, showing data 

selected from one or more columns in a 
spreadsheet. Graphs, in turn, can be 
incorporated into preformatted tabular reports, 
and 

 C. Preformatted tabular reports of data retrieved 
from particular flow monitoring stations. 

 
 Spreadsheets, graphs, and reports that you have 
prepared can be sent to either a color or monochrome 
printer. They can be stored as files on disk for later review 
or for transfer to other computers. 
 
 Besides being used in the office for purposes such as 
these, Q-Tracker Windows also provides the same functions 
as the DOS program. It can be used in the place of DOS, for 
setting up and calibrating Q-Tracker monitors and retrieving 
flow data from them. These meter communication 
capabilities are provided as a convenience for users who 
happen to have portable computers equipped with Microsoft 
Windows and a suitable cursor pointing device such as a 
trackball. These features also allow you to communicate with 
Q-Tracker units using Q-Tracker Windows on the office 
computer. Thus you can use the office computer to setup and 
calibrate Q-Trackers before taking them into the field for 
installation. You can also retrieve data from Q-Trackers that 
have been removed from service and returned to the office. 
 
1.3 Hardware and Operating System Requirements 
 For running Q-Tracker, it is recommended that you 
use equipment with the capabilities listed below. You 
might get by with less, but you will not achieve full 
benefit of all the program’s features. For questions on 
equipment compatibility, consult the factory. 
 
 • IBM PC/AT-compatible computer with 386 or 

better CPU, running at 25 megahertz or faster 
 • 4 megabytes or more of RAM 
 • 10 megabytes or more of available fixed-disk 

storage 
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 • An available serial (COMM) port if you wish to 
communicate with Q-Tracker flow monitors 
using this computer 

 • Microsoft™ Windows, Version 3.1 or  
Windows™ 95 

 • A mouse or equivalent cursor pointing device 
suitable for working in Windows, such as a 
trackball 

 • A color monitor, Super VGA, 0.28-mm dot pitch 
or better, screen size 7 inches or larger 

 • A color graphic printer such as laser or ink-jet, 
and a suitable printer driver installed in the 
Windows system 

 
1.4 Factory Technical Assistance 
 Customers who have questions beyond what is 
covered in this manual may obtain technical assistance 
from Badger Meter, Inc. In Tulsa by telephoning the toll 
free number 1-800-226-FLOW (3569). 
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Figure 2-1 
Opening Menu Bar and Icon Tool Bar, showing menus pulled down from the menu bar 

 
 
 
2.1 Installing Q-Tracker in the Computer 
 Q-Tracker is normally provided to users on three 3-
inch, high-density (1.4-megabyte) diskettes labeled Disk 
1, Disk 2, and Disk 3. It is assumed that Windows 3.1 is 
running. Q-Tracker is installed (setup) like other typical 
Windows applications as follows: 
 A. Insert Disk 1 into the appropriate drive (Drive 

B, for example purposes). 
 B. In the Program Manager window pull down the 

File menu, and choose Run. 
 C. In the Run window enter the drive and program 

name, B:SETUP, in the Command Line box. Do 
not select “run Minimized”. Press the Enter key, or 
click on the OK button to start the setup program. 

 D. A window will give you the opportunity to specify 
a directory on the hard disk where you want the 
main Q-Tracker application program to be stored. 
This program is called QTRAKWIN.EXE. 
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  Unless you key in another directory here, 
QTRAKWIN.EXE will be put in a directory 
called QTRACKER on the fixed disk from 
which Windows is operated (assumed here to be 
Drive C). In any case, the QTRACKER 
directory will be created on that disk. This is 
where Q-Tracker will automatically store flow 
data retrieved from Q-Tracker monitors, as well 
as any setup data files that are created. 

 

 
 
 E. After setup is complete, you will find the Q-

Tracker application icon in a newly created 
program group called Qtracker, shown below. 

 

 
 
2.2 Navigating in Q-Tracker 
 Like any other Microsoft Windows application, Q-
Tracker is started by double-clicking on the application 
icon. You may exit the program by clicking on the Exit 
icon in the tool bar or by choosing Exit Q-Tracker in the 
File menu at the opening menu bar. The basic procedures 
are as in other Windows applications. Within the program, 
windows can typically be moved, sized, minimized, 
maximized, restored, and closed. 
 
 The remainder of Section 2 consists of a quick start 
guide. Here you will find brief explanations of the bare 
essentials for using Q-Tracker. For more details, refer to 
appropriate other sections of the manual. 
 
 To follow the quick start guide, you will have to 
understand how to navigate in Q-Tracker, meaning find 
your way from one menu to another. The row of menu 
names found at the top of the screen, above the icon tool 
bar, is called a menu bar (Figure 2-1). A menu is a list of 
options that appears when you select its name in the menu 
bar. Selecting a menu is commonly called pulling it down, 
and menus are sometimes called “pull-downs”. The icon 
tool bar remains the same, regardless of which menu bar is 
displayed. 
 
 When you are using Q-Tracker, it is always 
operating in one of four modes. Each mode has its own 
menu 
bar, consisting of a different list of menus, as follows: 
 
 

 A. The opening mode. The menu bar for this mode 
comes up when you start the program, and 
whenever you close all windows of the 
following types. Six opening menus are listed in 
the bar (Figure 2-1). See Section 3 for more 
details. 

 B. The spreadsheet mode. The menu bar for this 
mode comes up whenever a spreadsheet 
window is active. Obtain a spreadsheet window 
(one spreadsheet per window) by choosing 
Spreadsheet in the Data menu at the opening 
menu bar, or by clicking on the Spreadsheet 
icon in the tool bar. Five spreadsheet menus are 
listed in the bar. See Section 4 for more details. 

 C. The graph mode. The menu bar for this mode 
comes up whenever a graph window is active. 
Obtain a graph window (one graph per window) 
by choosing Graph Selected Data in the Graph 
menu at the spreadsheet menu bar, or by 
clicking on the Graph icon in the tool bar. Five 
graph menus are listed in the bar. See Section 5 
for more details. 

 D. The report mode. The menu bar for this mode 
comes up whenever a report window is active. 
Obtain a report window (Figure 2-1) by pulling 
down the Data menu at the opening menu bar 
and choosing Report, or by clicking on the 
Report icon in the tool bar. Four report menus 
are listed in the bar. See Section 6 for more 
details. 

 
 You can have windows of all three types at the 
same time. You can have more than one spreadsheet 
window and graph window, but only one report window. 
However, as in other Windows applications, only one 
window will be active at a given time. The active window 
is one you have selected by clicking anywhere in it. You 
can also select windows by other means, including the list 
in the Window menu in each menu bar. 
 
 To get back to the opening menu bar, you have to 
close all spreadsheet, graph, and report windows. 
 
 
 
2.3 Transferring Data Files from Field Computers  
 to the Office Computer 
 The files in question are Setup Data files and Flow 
Data files. The typical procedure is to use a diskette drive 
as the default drive in the field computer. Thus as data 
files are created, they are stored on diskettes. Take the 
diskettes to the office computer and copy the files onto its 
hard disk. Put each file in the QTRACKER directory and 
in the same subdirectory where it was stored in the field 
computer. The name of this subdirectory will be the study 
name. A typical directory path in the office computer 
might be C:\QTRACKER\SOUTH1. 
 
 Of course, the field computer can put files on its 
hard disk instead of diskettes. In that case, use DOS (or  
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Windows, if you have it) to copy the files to diskettes for 
transfer to the office computer. If the data will fill up more 
than one disk, you may wish to use the DOS BACKUP 
and RESTORE commands instead of the COPY 
command. 
 
 If you are equipped to transfer files directly from 
the field computer hard disk to the office computer hard 
disk, you might prefer to do that instead. One possible 
method is to use appropriate communications software 
and a cable between serial data ports. Modems may be 
included if the distance is more than a few feet. Another 
possible method is to transfer files via a local area 
network. 
 
2.4 Creating and Manipulating Spreadsheets 
 A. Measurement units for flow data are selected 

before obtaining a window in which to view the 
data. To review and change units for level, 
velocity, and flow, pull down the Defaults menu 
in the opening menu bar, and choose Measuring 
Units. 

 B. Open a window with an empty spreadsheet: 
Click on the Spreadsheet icon in the tool bar, or 
pull down the Data menu at the opening menu 
bar and choose Spreadsheet. The opening menu 
bar changes to the spreadsheet menu bar. You 
can open additional spreadsheets by choosing 
New in the File menu at the spreadsheet menu 
bar. The windows are numbered: Spreadsheet 1, 
Spreadsheet 2, etc. 

 C. Time averaging of flow data is done when the 
flow data file is opened. Before opening a file, 
you may select daily, hourly, or no averaging by 
choosing Averaging in the Options menu at the 
spreadsheet menu bar. 

 D. Put flow data into the active spreadsheet by 
choosing “Open Datafile” or “Open Datafile 
(Start/Stop)” in e File menu at the spreadsheet 
menu bar. The Start/Stop option lets you select a 
range of data instead of reporting the entire data 
file. If you want to stop insertion of a long file, 
choose Close Datafile in the same pull-down. 
Insertion starts on the line you have selected by 
clicking on a cell. You Can perform multiple 
insertions into one spreadsheet, provided that all 
the data inserted are from the same study and 
location. 

 E. Editing and calculations: Double-click on any 
cell (little number box) in the report, then use 
conventional Windows text editing techniques 
in that cell. Select cells, groups of cells, and 
groups of lines by clicking and dragging, then 
use the Edit menu at the report menu bar to cut, 
copy, and paste (within certain limits). You can 
select entire columns by clicking in the header 
(top label) of the column. You can label  
 

 

 
  columns, paste data from one spreadsheet into 

another, and setup automatic calculations 
amongcolumns within a line. See Section 4 for 
more details. 

 F. Designing spreadsheet formats: In the Options 
menu, you can select type fonts, column widths, 
and colors for the active spreadsheet at any 
time. These format choices remain applicable to 
future spreadsheets having the same window 
number (Spreadsheet 1, Spreadsheet 2, etc.). 

 G. Storing and retrieving a spreadsheet: Use the 
Save, Save As, and Load commands in the File 
menu at the spreadsheet menu bar. 

 H. Printing a spreadsheet: Use the Print command 
in the File menu at the spreadsheet menu bar. 

 
 
2.5 Generating Graphs 
 
2.5.1 Basic Concepts 
 A Q-Tracker graph is a visual representation of 
data in one or more columns of a Q-Tracker spreadsheet. 
Each column of numbers that you select in the spreadsheet 
(or a selected group of lines within a column) becomes a 
plot in the graph. Thus, to create a graph, you must first 
work up a spreadsheet (Section 2.4). The horizontal X 
axis represents the dates and times at which flow 
measurements were taken, shown in the far left column of 
the spreadsheet. The vertical Y axis represents numerical 
values in other spreadsheet columns, such as inches of 
water level or cubic feet per second. A graph consists of 
one or more plots from the same spreadsheet, all on the 
same axis and all of the same selected type. Each plot in a 
graph is identified by color and (for black-and-white 
reproduction) by pattern. Each graph has its own 
numbered window. You can create more than one graph 
from a spreadsheet. Graph 1 does not necessarily 
correspond to Spreadsheet 1, etc. 
 
2.5.2 Basic Procedures 
 A. Select data to be plotted: Click on a column 

header in the spreadsheet to select all values in 
that column. (Selected values are highlighted by 
black background.) Click and drag within a 
column to select a group of values. Click and 
drag across columns or column headers to select 
a group of columns. 

 B. Open a graph window by clicking on the Graph 
icon in the tool bar or on the Graph menu at the 
spreadsheet menu bar. 

 C. Select graph details by experimenting with the 
pull-down menus in the graph menu bar. Look 
at the control Panel selected in the View menu. 
Try the various options available through the 
Type menu and the Options menu. These format 
choices remain applicable to future graphs 
having the same window number (Graph 1, 
Graph 2, etc.). 



8 

 
 
 D. Storing and retrieving a graph:  Use the Save 

and Load commands in the File menu at the 
graph menu bar. 

 E. Printing a graph:  Use the Print command in the 
File menu at the graph menu bar. 

 F. Generating more than one graph:  Open 
another graph window with the New Graph 
command in the File menu at the Graph menu 
bar. When you generate a graph, it goes into the 
most recently selected graph window. 

 
2.6 Creating Preformatted Flow Reports 
 A. Measurement units for flow data are selected 

before obtaining a window in which to view the 
data. To review and change units for level, 
velocity, and flow, pull down the Defaults menu 
in the opening menu bar, and choose Measuring 
Units. 

 B. Open the Report Manager window: Click on the 
Report icon in the tool bar, or choose Report in 
the Data menu at the main menu bar. 

 C. Time averaging of flow data is selected in the 
Report Manager window under the Report Type 
area. The choices are: no average, 15 minute 
average, hourly average and daily average. The 
Custom reports choice under the Report Type 
give access to custom reports from the Report 
Library. This is explained in more detail in 
Section 6. 

 D. Generate a report by clicking on the Data File 
name button and then selecting the data file 
from the file selection window. The Report 
window will appear and the report will be 
displayed as it is being generated. 

 E. Printing a report is accomplished by clicking on 
the Print icon at the bottom of the Report 
window. A print window will appear allowing 
the user to select the pages to be printed. 

 F. A report can be saved for exporting in another 
format. Click on the Suitcase icon and the 
export window will appear. Select the format 
desired from the list. See Section 6 for a 
detailed explanation. 

 
2.7 Interacting With a Q-Tracker Unit 
 
2.7.1 Connection and Preparation 
 A. Connect an appropriate cable between a serial 

data port on the office computer and the Q-
Tracker’s interrogator communication cable. 

 B. Pull down the Defaults menu at the opening 
menu bar and choose Comm Port, then choose 
the port where the cable is connected. 

 C. You may also wish to look at the measuring 
units presently in effect and select others instead 
by choosing Measurements in the Defaults 
menu at the opening menu bar. However, you 
 

 

 
 
  can change these units later, as necessary, 

whenever you like. 
 
2.7.2 Viewing Q-Tracker Unit Operation 
 Click on the human eye icon in the tool bar, or use 
the Communicate menu at the opening menu bar and 
choose View Q-Tracker Operation. The Q-Tracker wakes 
up and starts feeding real-time measurement data to a 
window on your screen. Readings are updated at intervals 
of about one second. 
 
2.7.3 Viewing Setup Data in the Q-Tracker Unit 
 Click on the Setup Data icon in the tool bar, or use 
the Communicate menu at the opening menu bar and 
choose Setup Data. A Setup Data window appears. In the 
Setup Data Window, click on the Get button. Q-Tracker 
communicates with the Q-Tracker unit and shows you the 
present setup data. 
 
2.7.4 Changing Setup Data in the Q-Tracker Unit 
 You can do this in any of three different ways. You 
will be reminded that changing setup data in the unit also 
erases stored flow data, so you can stop to avoid erasing 
the stored data. 
 
 A. Get the existing setup data from the Q-Tracker 

unit as explained in Section 2.7.3, make changes 
in the various boxes in the Setup Data window, 
and click on the Send button in that window. 
Then to save a copy of the changed setup data 
file in the computer, click on the Save button in 
the Setup Data window. 

 B. You can modify an existing setup data file 
stored in the computer and send it to the Q-
Tracker unit. In the File menu at the opening 
menu bar, choose Setup Qtracker, then select a 
stored file using the Fileopen window. A Setup 
Data window appears identical to the Setup 
Data window in Section 2.7.3. Click on the 
Open button. The Fileopen window appears. 
Select the setup file to be modified. After 
changing any of this data, click the Send button 
to put it into effect I the Q-Tracker unit. Click 
the Save button to save the revised setup data as 
a file in the computer. If you have changed the 
study name or site ID, the revised data goes into 
a new setup data file under that designation, 
instead of replacing the old file. (If the study 
name is a new one, a new subdirectory is 
created for it.) 

 C. You can create a new setup data file from 
scratch. In the File menu at the opening menu 
bar, choose Setup Qtracker or click on the Setup 
Data icon. A Setup Data window as in Step B 
above appears, but with all the boxes blank. Fill 
then in, then continue as explained for changing 
an existing file in Step B. 
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2.7.5 Retrieving (Downloading) Measurement Data 
 Retrieval of data from a Q-Tracker unit is called 
download. You may download all of the data stored in 
memory, or only the data stored since the last time data 
was downloaded. Click on the Download Data icon in the 
tool bar, or pull down the Communicate menu at the 
opening menu bar and choose Download Data. When 
using the Download Data icon, a box will appear giving 
you a choice of a Full Download or Since Last Time. A 
Download window appears, giving you the opportunity to 
select the disk where the retrieved data will be stored. 
There are also two buttons for downloading the data, the 
‘Full Download’ button or the ‘Since last Time’ button. 
All flow data in the Q-Tracker unit is copied to a file on 
the selected disk. It goes in a directory called 
QTRACKER and a subdiretory of the same name as the 
study (according to setup data in the Q-Tracker unit). The 
file is given a Filename consisting of the date and hour, 
with an extension consisting of the “at” sign @ and the 
site number. The flow data file also contains the setup 
data that was in effect  
 
 

 
 
when the measurements were taken. (You can change 
some of the setup data in a data file later, using the Edit 
menu.) You will be given an opportunity to erase all flow 
data in the Q-Tracker unit after the downloading has been 
completed. 
 
2.7.6 Calibrating the Level Sensor 
 The ultrasonic velocity sensor never requires 
calibration, but the hydrostatic level sensor does. For 
information about sensor calibration and other aspects of 
the Q-Tracker flow monitor, see the Installation and 
Operation Manual. 
 
 It is assumed that you have connected an 
appropriate cable between a serial data port on the 
computer and the Q-Tracker’s interrogator communication 
cable. To use the Q-Tracker program for calibrating the 
level sensor, click on the Calibrate icon in the tool bar, or 
choose Calibrate Level in the Communicate menu at the 
opening menu bar. This brings up the Sensor Calibration 
window. Instructions in the window will steer you through 
setting the sensor zero and span. 
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Data
  Spreadsheet
  Report

Defaults
Measuring Units
Comm Port

Level

Velocity
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MGD
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M3H
MLD

Window

Cascade
Tile
Arrange Icons

Toolbar
About Qtracker . . .

Edit
  Edit datafile setup

File
Setup QTracker. . .
Ex it Q-Tracker

Reset to Defaults
Calibrate Level
Battery Analysis

Communicate
View Q-Tracker operation
Download Data
Setup Data . . .
Set Time/Date

FIGURE 3-1 
Open menu bar and icon tool bar, showing menus pulled down from the menu bar  

 
TABLE 3-1. Functions of Items in the Opening Menus 

 
 Menu Item Section Function 
 
File View Q-Tracker Operation . 3.3.1....  Create a new setup data file to program a Q-Tracker for a specific site 
  Exit Q-Tracker.................... 3.3.2....  Exit the Q-Tracker program 
Communicate View Q-Tracker Operation . 3.4.1....  Monitor operation of a Q-Tracker instrument connected to the computer 
  Download Data ................... 3.4.2....  Retrieve all stored flow data from the Q-Tracker 
  Setup Data........................... 3.4.3....  Load or retrieve a setup data file into/from the Q-Tracker 
  Set Time/Date ..................... 3.4.4....  Set the calendar and clock in the Q-Tracker 
  Reset to Defaults................. 3.4.5....  Reset the Q-Tracker to factory default setup data 
  Calibrate Level ................... 3.4.6....  Calibrate the zero and span of the level sensor 
  Battery Analysis.................. 3.4.7....  Display Q-Tracker battery voltage and approximate remaining battery life 
Edit Edit Datafile Setup.............. 3.5.......  Change parameters in a flow data file for calculations from measurements 
Data Spreadsheet......................... 3.6.1....  Activate a spreadsheet window to insert a flow data file 
  Report ................................. 3.6.2....  Activate the report window to create a preformatted report from flow data 
  Graph Icon .......................... 3.6.3....  Activate a graph from data selected on a spreadsheet 
Defaults Measuring Units ................. 3.7.1....  Change level, velocity, and flow units in reports, spreadsheets, & graphs 
  Comm Port.......................... 3.7.2....  Select serial port on computer for connecting with a Q-Tracker monitor 
Window Toolbar ............................... 3.8.......  Activate or deactivate the icon tool bar 
  About Qtracker ................... 3.8.......  Provides information about program 
  Cascade............................... 3.8.......  Arrange open windows in cascade format as other Windows applications 
  Tile...................................... 3.8.......  Arrange open windows in tile format as in other Windows applications 
  Arrange Icons ..................... 3.8.......  Automatically arrange visible Windows icons 
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3.1 Introduction 
 This Section 3 of the manual provides detailed 
explanations of Q-Tracker operations in the opening mode 
(Section 2.2). These are functions available through the 
opening menu bar and icon tool bar. Most of the opening 
menu functions pertain to on-line interaction with a Q-
Tracker flow monitor. This includes getting flow data and 
setup data from the instrument as well as sending setup 
and calibration data to it. 
 Refer to Section 2.2 for an introduction to the menu 

structure by which Q-Tracker is used. 
 Refer to Section 2.3 for an introduction to transfer of 

setup data files and flow data files from field 
computers to the office computer. 

 Refer to Section 2.7 for an introduction to the use of 
Q-Tracker in field computers for 
communicating with Q-Tracker monitors. 

 Refer to Figure 3-1 for the names of the icons and a 
list of all pull-down menus available from the 
opening menu bar. 

 Refer to Table 3-1 for a summary of the functions of 
the icons and menu items. 

 
3.2 Using the Tool Bar Instead of Menus 
 As you will see in Figure 3-1, the icons in the tool 
bar duplicate some, but not all, of the functions in the 
opening menus. In addition, there is one icon, called 
Graph, that duplicates a function called Graph Selected 
Data in the Spreadsheet menus (Figure 5-1). Clicking on 
an icon has the same effect as choosing the item of that 
name in a menu. 
 
 If you want to provide more work space in the 
display, you can hide the tool bar and get along without it. 
To toggle it on or off, choose Toolbar in the Window 
menu. 
 
 The tool bar has two useful purposes. First, clicking 
on an icon can be faster and more convenient than pulling 
down a menu and choosing an item. Second, you can 
perform functions from the opening menus while working 
on a spreadsheet or graph, without having to get back to 
the opening menu bar. For instance, suppose you are busy 
in a spreadsheet and graph when someone brings in a Q-
Tracker unit for checking the battery and resetting the 
clock. You don’t have to save your work, close those 
windows, get to the opening menu bar, use the 
Communicate menu, then load your spreadsheet and graph 
again. Instead, just hook up the Q-Tracker to the computer 
and use the Battery Analysis and Set Time/Date icons. 
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3.3 The File Menu and the Setup File Window 
 
3.3.1 “Setup Qtracker” 
 This command is used to create a new Setup Data 
file for programming the Q-Tracker. It calls up the Setup 
 
 
 

Data window with default entries shown in Figure 3-2, 
Page 13. The Setup Data icon (see Figure 3-1) can also be 
used to bring up the Setup Data window, except the New 
button must be clicked on to enter a new Setup Data file. 
The application types available for selection are listed in 
the illustration. Selecting an application type here 
determines the kind of flow calculations Q-Tracker will 
make for this site (or whether it will report only level or 
velocity readings). Velocity default, level offset, velocity 
Kfactor, silt depth, recording interval, and rainfall counter 
are explained in the Q-Tracker Installation and Operation 
Manual. 
 
 When Circular Mannings or Rectangular Mannings 
has been chosen as the application type, the Mannings 
Calculation window (shown below) appears for your entry 
of the necessary parameters. Selecting one of the common 
conduit materials automatically inserts a typical 
coefficient for that material or you may enter the value. A 
slope value must also be entered. 
 
 

  
 
 When you have finished entering the desired 
information in the Setup Data window (and Mannings 
Calculation window, if applicable), you may transfer 
(upload) this data directly to a Q-Tracker connected to the 
computer. Do this by clicking on the “Send” button in the 
Setup File window. The procedure from at point is as 
described in Section 3.4.3, except that you don’t get a file-
selection dialog box. 
 
 To save the setup data you have finished entering in 
the Setup Data window (and associated Mannings 
Calculation window), click on the “Save” button in that 
window. Q-Tracker stores the file in the QTRACKER 
directory on the disk where the Q-Tracker program 
QTRACKER.EXE is stored. (See Section 2.1-D.) The file 
goes into a subdirectory having the same name as the 
study name in the window. If there is no directory by that 
name, Q-Tracker creates one. The filename also is the 
study name, with an extension consisting of an ampersand 
(&) followed by the site identification (ID) in the window. 
CAUTION: If there is already a setup file by that name on 
the disk, it gets overwritten by the new one.
 
3.3.2 “Exit Q-Tracker” 
 This command has the same effect as the Exit icon in 
the tool bar (Figure 3-1). You can also exit the Q-Tracker 
program by common Windows application methods: double 
- 



 
 
click on the Control Menu box, or choose Close in the 
control menu after clicking on the Control-Menu box, or 
press the Alternate and F4 keys. 
 
3.4 The Communicate Menu 
 
3.4.1 “View Q-Tracker Operation” 
 This command has the same effect as the icon with 
the same name in the tool bar (Figure 3-1). Q-Tracker 
immediately wakes up the Q-Tracker monitor connected 
to the computer. (Connection is described in Section 
2.7.1.) Real-time measurements appear in an Operation 
window as follows, updated at intervals of about one 
second: 
 
 

 
 
 
 The Communication Status panel in the window, 
reports stages in the process of establishing 
communication with the Q-Tracker unit. This should be 
completed within a few seconds. If Q-Tracker does not get 
a normal and reliable response from the monitor, you will 
be notified in the Communication Status panel. 
 
 Measurement units in the display are the ones 
currently in effect for all Q-Tracker operations. You may 
change these units at any time by selecting Measurements 
in the Defaults menu. 
 
 The Q-Tracker unit remains awake until you break 
the communication by closing the window. (Use that 
window’s Control-Menu box or the Exit button.) Then it 
returns to its normal cycle of battery-conserving sleep 
interrupted by brief awake periods. 
 
3.4.2 “Download Data” 
 This command has the same effect as the icon by 
that name in the tool bar (Figure 3-1). The purpose is to 
 
 

 
retrieve all the flow measurement data stored in a Q-
Tracker monitor connected to the computer and store it as 
a file in the computer. This file also contains the setup 
data that was in effect when the measurements were taken. 
You can change some of the setup data in a flow data file 
later, using the Edit menu (Section 3.5). 
 
 When the Download window appears, you may 
select the disk drive where the new data file will be stored. 
On that disk, the file is placed in a directory called 
QTRACKER. It goes in a subdirectory having the same 
name as the study according to the setup data in the Q-
Tracker unit. The file is given a filename consisting of the 
date and hour, with an extension consisting of the “at” 
sign @ followed by the site ID number. 
 
 Click on the ‘Full Download’ or ‘Since last Time’ 
button to begin the downloading of the data. Selecting the 
Full Download button downloads all the data stored in 
RAM. Selecting the Since last Time button downloads all 
the data stored since the last download. Events in e 
downloading process are reported in the window. Upon 
successful completion, a “Memory Clear Warning” dialog 
box appears as shown below: 
 
 

Download
Download File Q-Tracker Data

Full Download

Since Last Time

Exit

05259411.@6

Download Filename

Percentage Complete

6 South1

Site ID Study Name

14:59  05/16/94

Last Download

338 bytes

Amount

Download Drive Block Status Communication Status

7 0
Transfered Corrections

C: c.

100 %

Choice Selection
Status: File sent successfully

OK Cancel

This procedure will clear out the Q-Tracker data stored in its memory. Are
you sure you want to begin?

Q-Tracker Memory Clear Warning

 
 
 
 Clicking on the OK button clears accumulated flow 
data from the Q-Tracker monitor’s memory. Clicking on 
the Cancel button leaves the stored data in the monitor for 
the time being. The monitor remains awake until you 
make this choice. 
 
 
3.4.3 “Setup Data” 
 This command is to transfer an existing setup file 
from storage on disk to a Q-Tracker unit connected to the 
computer, or get the Setup Data from a Q-Tracker. 
Clicking on the Setup Data icon will accomplish the same. 
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APPLICATION TYPES 

 
Level measurement only 
Level and velocity measurement only 
Flow calculations: 
 Velocity times area, circular pipe 
 Velocity times area, rectangular pipe 
 Mannings method, circular pipe 
 Mannings method, rectangular pipe 
 Parshall flume 3 to 96 inches 
 Trapezoidal flume, 12 to 120 inches 
 Manhole flume, 6 to 12 inches 
 Leopold Lagco flume, 8 to 48 inches 
 V-notch weir, 30 to 90 degrees 
 Contracted weir, 18 to 96 inches 

Mannings Calculation

Coefficient

Roughness Coefficient Selection

Various Materials Slope

Slope Entry

 
 
 
 
 
 

FIGURE 3-2. Setup Data Window 
 
 
 
 Activating this command causes the Setup Data 
window to open as shown in Figure 3-2. To open an 
existing Setup Data file click on the Open button. The 
Fileopen window will appear as shown below. Choose the 
file you wish to transfer, using common Windows 
application methods. The Setup Data window will return 
with the data from the selected file. 
 
 

 
 
 
 To send the Setup Data file to the Q-Tracker, click 
on the Send button. You will be warned that the transfer 
will erase all measurement data stored in the Q-Tracker. 
 
 

?
Sending the setup data to the Q-Tracker will clear the logged
data. If this data is important first download the data from the
Q-Tracker and then transfer the setup data. If you want to continue
to transfer the setup data select OK else select Cancel.

Setup data Transfer Warning

OK Cancel
 

 
 
 
 
 Next, the Setup Transfer window appears, showing 
you the progress of the transfer and ending as shown 
below with an opportunity to reset the Q-Tracker clock. 
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 If you click on the OK button at this point, you next 
get a Set Time/Date window; see the following Section 
3.4.4 for instructions. 
 
 To retrieve the Setup Data file from the Q-Tracker, 
click on the Get button. In the Communications Status box 
there will be an indication that communication is being 
made with the Q-Tracker. The Setup Data from the Q-
Tracker will be inserted into the data boxes. 
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3.4.4 “Set Time/Date” 
 This command has the same effect as the icon 
having the same name in the tool bar (Figure 3-1). The Set 
Time/Date window appears as shown below. 
 
 

Status:   online

Communication Status

05/25/9413:4813:48 05/25/94

Set Time / Date

SEND

EXIT

Q-Tracker Desired

 
 
 
 The Desired time and date box shows values from 
the computer’s clock and calendar circuit as of the 
moment this window appears. You may change these 
numbers to whatever you desire. So long as this window 
remains open, the Q-Tracker time and date box is updated 
at frequent intervals. Click on the Send button to put the 
new desired time and date into effect in the Q-Tracker. 
 
3.4.5 “Reset to Defaults” 
 There is no icon in the tool bar corresponding to 
this command. The purpose is to reset or reinitialize the 
microprocessor electronics in the Q-Tracker unit 
connected to the computer. All flow data and setup data in 
the Q-Tracker unit are erased. (However, the clock and 
calendar circuitry is separate and is not reset.) The unit 
starts operating again with setup data consisting of 
standard default values permanently programmed into a 
ROM (read-only memory) at the factory. This can 
sometimes cure malfunctions in execution of the 
microprocessor’s internal program. Also, restoring the Q-
Tracker to a standard condition can sometimes be helpful 
in troubleshooting. 
 
 Before carrying out the reset command, Q-Tracker 
gives you the warning below. You may wish to retrieve 
and save the Q-Tracker unit’s flow data and setup data 
before continuing (Sections 3.4.2 and 3.4.3). 
 
 

 
 
 
 If you click on the OK button, the reset is done 
immediately, indicated by the following window which 
appears on your screen for a brief period: 
 
 

 

 
 
 
3.4.6 “Calibrate Level” 
 This command has the same effect as the icon by 
the same name in the tool bar (Figure 3-1). The purpose is 
to calibrate the zero and span of the level sensor for a Q-
Tracker monitor connected to the computer. (The 
ultrasonic velocity sensor never requires calibration.) The 
level sensor actually detects water pressure. The depth 
down to the pressure port on the probe unit is then 
calculated from the measured pressure. It is best to do 
both zero and span calibrations rather than one or the 
other. This requires removing the probe from service and 
providing water in a suitable container such as a barrel or 
large bucket. This command calls up the Sensor 
Calibration window. 
 
 Do the zero calibration first. Place the probe unit in 
a normal horizontal position, out of water, stationary and 
free of vibration. Click on e Zero button. The Q-Tracker 
wakes up and the progress of the procedure is displayed in 
the Communication Status panel. This will take about 30 
seconds. 
 

The sensor ZERO is set by having the
sensor out of the water and then pressing
the ZERO button.

The sensor SPAN is set by measuring the
depth and subtracting the sensor
offset. Then the value is entered in the
following box. Then press the SPAN button.

IN.

Measured DEPTH entry

Sensor Calibration

Communication Status

Status:   Waiting to begin

ZERO SPAN CANCEL
 

 
 For the span calibration, place the probe unit in a 
normal horizontal position, stationary and free of 
vibration, submerged in still water at a suitable depth. For 
typical installations, the recommended depth is 
approximately half the diameter of the pipe or channel. 
However, it must  
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not be less than 10 inches. Measure the depth from the 
water surface down to the pressure slot on the probe. The 
slot is 0.25 inch above the bottom of the sensor. This 
quarter inch is the level offset that is supposed to be 
included in e setup data in the Q-Tracker. For example, if 
the water is 12 inches deep and the probe is lying flat on 
the horizontal bottom, the depth to the pressure slot is 
11.75 inches. Key this value into the box in the Sensor 
Calibration window, using measuring units shown under 
the box (inches, feet, millimeters, or meters). You can 
change the units at any time with the Defaults menu 
(Section 3.7). Click on the Span button to start the 
calibration. Once again, the Q-Tracker wakes up and the 
progress of the procedure is displayed in the 
Communication Status panel. This will take about 30 
seconds. 
 
 After successful calibration of zero and span, leave 
the probe in the water and verify proper operation of the 
sensor as follows: Click on the “View Q-Tracker 
Operation” icon (Section 3.4.1) and observe the level 
reading. It should be 0.25 inch greater than the calibration 
span you keyed in. If not, make sure the setup data in the 
Q-Tracker includes a proper level offset of 0.25 inch. 
Move the probe to a different measured depth if you like. 
Take the probe out of the water and hold it level in the air. 
Each time, after a few seconds for sensor stabilization and 
data transmission, the display should read within 0.2 inch 
of the actual depth to the bottom of the probe. 
 
3.4.7 “Battery Analysis” 
 This command has the same effect as the icon by 
the same name in the tool bar (Figure 3-1). Q-Tracker 
wakes up the Q-Tracker unit connected to the computer 
and keeps it awake while displaying the battery voltage 
and remaining life in the Battery Analysis window below. 
The remaining life is an approximate projection based on 
measured voltage and the type batteries being used, 
assuming typical temperatures and typical Q-Tracker duty 
cycles. If you know the type of the batteries in the Q-
Tracker unit, select that type in the window. This battery 
type selection is not part of the setup data file, so it is not 
automatically changed. For a proper projection of 
remaining life, you must verify the battery type for each 
Q-Tracker unit you connect with. 
  

Communication Status

Status:    online EXIT

Battery Analysis

11.4 volts 46 days Alkaline
Standard
Heavy Duty
Alkaline

Battery Voltage Remaining Life

 
 
 
 

 
3.5 The Edit Menu 
 As you will see in Figure 3-1, this menu consists of 
only one item called Edit Datafile Setup. This command 
has the same effect as the icon by the same name in the 
tool bar. The purpose is to change certain setup data items 
in a flow data file stored in the computer. After using a 
File Selection dialog box (Section 3.4.3) to choose the 
data file, an Edit Data window appears (including a 
Mannings Calculation window if applicable) as follows: 
 

 
 
 Items that you are not allowed to change are shown 
in a lighter shade: study name, site ID, the three recording 
interval values, and enabling or disabling of the alternate 
interval and rainfall counter. All other items can be 
changed after the fact without affecting the accuracy of 
the measurements and the name of the data file. The 
changeable items are site description, pipe diameter, 
velocity default, level offset, silt depth, application type, 
velocity K factor and if the Mannings method is selected, 
the roughness coefficient and conduit slope. 
 
 After making the desired corrections, save the 
revised data file by clicking on the Save button. The Send 
button in this window is disabled. The edited file 
overwrites the original one. 
 
 Here is why you are allowed to make these changes 
after the flow measurements are recorded. When a flow 
data file is created upon downloading from a Q-Tracker 
unit, it contains all the setup data that was in effect during 
measurement. However, the measurements in the data file 
are simply raw numbers proportional to measured velocity 
and hydrostatic pressure. Whenever you open a data file 
into a report or spreadsheet, the desired values are 
calculated from the raw measurements. These calculations 
take into account the measurement units presently in 
effect in Q-Tracker. They also use certain setup 
parameters in the flow data file. These consist of all the 
setup parameters above which are allowed to be changed 
after the fact (except the site description, which is merely 
a convenience. 
 
 For instanced, after downloading a flow data file, 
suppose you realize that an error has been made in setup  
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data in the Q-Tracker unit. The pipe diameter is actually 
18 inches instead of 12 inches, and the silt depth is three 
inches instead of zero. You can correct the mistake with 
the Edit Datafile Setup command described here. The next 
time you open the data file in a report or spreadsheet, it 
will be correct. 
 
3.6 The Data Menu and the Graph Icon 
 
3.6.1 “Spreadsheet” 
 This command puts Q-Tracker out of the opening 
mode and into the spreadsheet mode. A blank spreadsheet 
window appears, and the menu bar changes from the 
opening menus (Figure 3-1) to the spreadsheet menus 
(Figure 4-1). For further operations from that point, see 
Section 4. 
 
 The Spreadsheet icon in the tool bar (Figure 3-1) 
has the same effect as the Spreadsheet command, but only 
when Q-Tracker is in the opening mode. In spreadsheet 
mode, the Spreadsheet icon has no effect. And in graph 
mode, the Spreadsheet icon switches to the spreadsheet 
mode, reactivating the most recently activated spreadsheet 
window on the screen. If there is no spreadsheet window 
already on the screen, a blank one appears. 
 
3.6.2 “Report” 
 This command puts Q-Tracker out of the opening 
mode and into the report mode. The Report Manager 
window appears. The Report icon in the tool bar (Figure 
3-1) has the same effect as the report command. For 
further operations from that point, see Section 6. 
 
 The Report icon in the tool bar (Figure 3-1) has the 
same effect as the Report command, but only when Q-
Tracker is in the opening mode. In Report mode, the 
Report icon has no effect, and in Spreadsheet or Graph 
mode, the Report icon switches to the Report mode. If 
there is a Report window which has not been closed, it is 
reactivated. If there is no Report window already on the 
screen, a blank one appears. 
 
3.6.3 The Graph Icon 
 The Graph icon in the tool bar (Figure 3-1) has the 
same effect as the Graph command in the Spreadsheet 
menu bar (Figure 4-1, Section 4-6). Clicking this icon puts 
Q-Tracker into Graph mode, described in Section 5. 
 
 
 
 
 
 
 
 
 
 

 
 
 
3.7 The Defaults Menu 
 

Defaults
Measuring Units
Comm Port

Com1
Com2
Com3
Com4

Level

Velocity

Flow

Inches (In)
Feet (Ft)
Millimeters (mm)
Meters (M)

Feet/Sec (F/S)
Meters/Sec (M/S)

MGD
CFS
GPM
L/S
M3H
MLD

 
 
3.7.1 “Measuring Units” 
 This command calls up the branching menu tree 
shown in Figure 3-1 and above. 
 
 Check marks in the level, velocity, and flow menus 
show which units are presently in effect for all Q-Tracker 
operations. You may change the units at any time by 
clicking on the ones you desire. Any spreadsheets, graphs, 
and reports created after  that point use the newly chosen 
units. But any spreadsheets, graphs, and reports that have 
been saved as files in the computer are not changed. They 
keep the units which were in effect when they were 
created. 
 
3.7.2 “Comm Port” 
 This command calls up the communications port 
selection menu shown in Figure 3-1 and above. You may 
connect Q-Tracker units to any or all of the listed serial 
communication ports which are available on your 
computer. A check mark indicates which port is presently 
selected. This is the port Q-Tracker will use the next time 
you try to communicate with a Q-Tracker unit. When you 
connect a Q-Tracker unit to your computer, you must find 
out which port you are using, and select that one in the 
communications port menu. 
 
3.8 The Window Menu 
 This menu is a standard one for Microsoft 
Windows applications. The commands in the menu should 
be familiar ones for Windows users. They are briefly 
explained in Table 3-1. 
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4.0  Spreadsheets
 
 
 

 
 

FIGURE 4-1 
The spreadsheet menu bar appears when a spreadsheet window is active. 

 
 
 
 

TABLE 4-1. Functions of Items in the Spreadsheet Menus 
 
 Menu Item Section Function 
 
File Open Datafile ....................... 4.3.1 ... Insert a flow data file into a spreadsheet form 
  Open Datafile (Start/Stop).... 4.3.2 ... Same as Open Datafile, but allowing selection of time period from the file 
  Close Datafile....................... 4.3.3 ... Stop inserting a flow data file into a spreadsheet form before completion 
  New ...................................... 4.3.4 ... Open another spreadsheet window 
  Load ..................................... 4.3.5 ... Display a previously created and saved spreadsheet in the active window 
  Save...................................... 4.3.6 ... Save the active spreadsheet, using same filename at last one saved 
  Save As ................................ 4.3.7 ... Save active spreadsheet (regular, comma or tab-delimited), specify filename 
  Print ...................................... 4.3.8 ... Print the active spreadsheet 
  Exit Spreadsheet................... 4.3.9 ... Return to opening mode 
Edit Cut ........................................ 4.4.1 ... Remove selected part of active spreadsheet and copy to spreadsheet clipboard 
  Copy ..................................... 4.4.2 ... Copy selected text from active spreadsheet to spreadsheet clipboard 
  Paste ..................................... 4.4.3 ... Paste text from spreadsheet clipboard into selected part of active spreadsheet 
  Clear Data............................. 4.4.4 ... Erase all measurement data from active spreadsheet, leaving headers, etc. 
  Clear All ............................... 4.4.5 ... Erase nearly everything from the active spreadsheet 
  Change Cell Values.............. 4.4.6 ... Change numerical value of cells 
  Change Column Headers...... 4.4.6 ... Change column headers 
  Automatic Calculations ........ 4.4.7 ... Inserting equations in spreadsheet columns 
Options Averaging............................. 4.5.1 ... Choose time averaging interval before opening data file to spreadsheet 
  Fonts..................................... 4.5.2 ... Choose font (type style and size) for the active spreadsheet 
  Column Width...................... 4.5.3 ... Set width of selected column in the active spreadsheet 
  Colors ................................... 4.5.4 ... Choose background and foreground (text) colors for active spreadsheet 
Graph Graph Selected Data............. 4.6 ...... Go to graph mode and graph selected data in active spreadsheet 
Window Toolbar ................................. 4.7 ...... Activate or deactivate the icon tool bar 
  Clipboard.............................. 4.7 ...... Activate the Microsoft Windows clipboard viewer 
  Cascade ................................ 4.7 ...... Arrange open windows in cascade format as other Windows applications 
  Tile ....................................... 4.7 ...... Arrange open windows in tile format as in other Windows applications 
  Arrange Icons ....................... 4.7 ...... Automatically arrange visible Windows icons 
  List of Existing Windows..... 4.7 ...... Activate desired window as though you had clicked on it 
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FIGURE 4-2. 
The beginning of a typical spreadsheet with hourly averaging 

 
 
 
4.1 Introduction 
 This Section 4 of the manual provides detailed 
explanations of Q-Tracker Window operations in the 
spreadsheet mode (Section 2.2). These are functions 
available through the Spreadsheet menu bar. The other 
three sets of menus (Opening, Graph, and Report menu 
bars) are explained in Sections 3, 5, and 6 of the manual. 
Most of the Spreadsheet menu functions pertain to 
creating, modifying, saving, retrieving, and printing 
spreadsheets containing flow data from Q-Tracker 
monitors. 
 
 To get into the spreadsheet mode, see Section 3.6.1. 
 
 Refer to Section 2.2 for an introduction the menu 

structure by which Q-Tracker is used. 
 Refer to Section 2.5 for an introduction to Q-Tracker 

spreadsheets. 
 Refer to Section 6.1 for a discussion of the difference 

between spreadsheets and preformatted reports. 
 
4.2 Spreadsheet File Formats: Regular Versus 
 Comma and Tab Delimited 
 Q-Tracker saves (stores) spreadsheets on disks in 
any of three file formats. Each uses a different filename 
extension as follows: 
 
 .SPR extension:  A special format used only by Q-

Tracker. This is the normal file format for saving 
spreadsheets for use by Q-Tracker. The file 
includes not only column headings and data, but 
also  
 

 

 
 
 
 
  setup data from the source flow data file, type style 

and size, colors, column widths, and formulas for 
computing certain columns from others. 

 .CSV extension: Comma-separated variable, also 
called comma-delimited fields. Standard ASCII 
characters with commas between data files on each 
line, for importing data into certain spreadsheet and 
database programs. Only column headings and data 
are included—no setup data, etc. 

 .TSV extension:  Tab-separated variables, also called 
tab-delimited fields. Standard ASCII characters like 
.CSV above, but with tab characters between data 
fields on each line rather than commas. Only 
column headings and data are included—no setup 
data, etc. Some spreadsheet and database programs 
import this format instead of .CSV format. 

 
4.3 The File Menu 
 
4.3.1 “Open Datafile”, Spreadsheet Windows,  
 and Spreadsheet Layout 
 This command works much like the Open Data 
command in the report mode. Use it to get an entire flow 
data file from a disk, displaying it in the active 
spreadsheet window. If there is already a spreadsheet in 
the window, it will be replaced with the new one, 
although that is not a recommended practice. 
 
 When a spreadsheet window is opened, it retains 
the averaging period, fonts, column widths, and colors  
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that were in effect the last time the spreadsheet with that 
number was closed. That may have happened in the 
current Q-Tracker session, or in a previous session. The 
averaging period that will be used is displayed in the top 
bar of the spreadsheet window. This may be a different 
averaging selection than in other spreadsheet windows. 
You may wish to change the averaging period before 
opening the desired spreadsheet (Section 4.5.1). Once a 
file is opened, the averaging period and the measuring 
units cannot be changed. 
 
 On choosing the Open Datafile command, a file 
selection dialog box appears which is typical of Microsoft 
Windows applications. The appropriate file type is already 
selected (extensions beginning with @):). 
 
 

 
 
 
 As soon as you choose a data file from a disk, Q-
Tracker starts working on inserting it into the spreadsheet. 
If the file is a long one, there will be a noticeable delay 
while the word “Inserting” flashes on and off in the status 
box in the top bar of the window (see Figure 4-2). The 
word “Calculating” briefly appears, then “Complete”. 
Before completion, you may stop the insertion process by 
choosing the Close Datafile command described in the 
following section. After completion, the status box is used 
for other purposes. 
 
 Other boxes in the top bar of a spreadsheet window 
show the filename of the flow data file, the time averaging 
in effect for this spreadsheet, the studyname, the site 
identification number (ID), and the beginning and ending 
times and dates for the data in the spreadsheet. 
 
 As seen in Figure 4-2, a typical spreadsheet initially 
has columns for date and time together, level, velocity, 
and volumetric flow rate. In addition, if the rainfall 
contact counter was enabled in the Q-Tracker setup, there 
is a rainfall column. Rainfall units are the same as for the 
level column. Eleven columns are available, labeled A 
through K when the spreadsheet is blank. Each line is 
numbered in a header column at the far left. The data lines 
are not interrupted by setup information and daily 
summaries as in a report (Figure 6-2). 
 
 
 
 

 The volumetric flow column is calculated by a 
formula established according to the application type in 
the setup data contained in the flow data file. Inputs for 
the calculation include variable data in one or more 
preceding columns as well as constants in the setup data 
file. For more about calculated columns, including 
calculations you can design, see Section 4.4.7. 
 
4.3.2 “Open Datafile (Start/Stop)” 
 This command has the same effect as the Open 
Datafile command in the preceding section, except that 
you are allowed to display a desired certain section of data 
from the file rather than the entire file. This is useful if 
you only need to look at data from a relatively short time 
period. You don’t have to wait for the whole file to be 
inserted, and you don’t have to scroll a long way down to 
find the data you want. However, Q-Tracker searches 
through the file for the selected period at the same speed it 
inserts spreadsheet data. Therefore if you specify a period 
near the closing end of the file, it will take just as long to 
insert it as if the entire file were inserted. 
 
 After choosing the file, a Start/Stop Time window 
as shown below appears. The upper panel shows the 
beginning and ending times and dates for the data in the 
file. Change the values in the lower Starttime and Endtime 
boxes to the ones you desire. Click on Continue to begin 
opening the file in the spreadsheet. If you specify a period 
which is not entirely covered by the data, or if you specify 
an end time that is before the start time, an appropriate 
warning box will appear. 
 

Start/Stop Time

14:29 10/21/93 14:29 10/21/93
Starttime Endtime

14:29    10/21/93 16:08    12/17/93
Data File Starttime Data File Endtime

CONTINUE CANCEL
 

 
4.3.3 “Close Datafile” 
 This command has no effect except while Q-
Tracker is carrying out an “Open Datafile” command or 
an “Open Datafile (Start/Stop)” command. The purpose is 
to help you save time by halting the insertion of an 
excessively long file, when you don’t need the entire file. 
 
 When you use the Close Datafile command during 
insertion of a file, the incomplete data that Q-Tracker has 
already inserted remains in the spreadsheet. This consists 
of the date/time, level, velocity, and rainfall columns, 
down to the last line inserted before you closed the file.  
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Then within a very brief time, the volumetric flow column 
is calculated down to the closing date and time. 
 
4.3.4 “New” 
 This command opens another spreadsheet window. 
The new window is assigned the lowest available number. 
For example, if you already have Spreadsheet 3 open and 
no other, the New command brings up Spreadsheet 1. The 
newly opened spreadsheet window is blank. It retains the 
selections of averaging period, fonts, column widths, and 
colors that were in effect the last time it was closed, in the 
current Q-Tracker session, or a previous session. 
 
4.3.5 “Load” 
 This command opens (displays) a previously saved 
spreadsheet in the active window. A file selection dialog 
box as shown below appears. The file type box in the 
lower left corner includes spreadsheet files of all three 
types (Section 4.2), with .SPR, .CSV, and .TSV filename 
extensions. 
 

 
 
 Loading a previously saved spreadsheet is much 
faster than initially creating a spreadsheet by opening a 
data file. After you load a spreadsheet file, the filename 
box in the top bar of the spreadsheet window does not 
show the name of the spreadsheet file. Instead, it shows 
the flow data file from which it was derived. However, the 
title bar at the very top of the window shows the directory 
path and filename of the spreadsheet file, rather than the 
number of the spreadsheet window as when a data file is 
opened into the window. Although the spreadsheet 
window number is not displayed, it remains the same. 
 
 Since a .SPR file includes Options Menu selections 
(averaging period, font, column widths, and colors), those 
selections come along when you load the file. They 
remain in effect for the active window until changed. 
Conversely, since .CSV and .TSV files do not include 
option information, loading a file of either type does not 
change the options currently in effect for the active 
window. 
 
4.3.6 “Save” 
 This command saves the active spreadsheet, storing 
it as a file on a disk. The filename and directory path used 
are the same as the last spreadsheet you previously saved  
 
 

 
or loaded for that window in this session with Q-Tracker. 
You are required to specify a filename and directory path, 
using a file selection dialog box very similar to the one 
shown in Section 4.3.5. You may specify .SPR, .CSV, or 
.TSV file format (Section 4.2). 
 
4.3.7 “Save As...” 
 Like the Save command, this one saves the 
spreadsheet which is presently in the spreadsheet window, 
storing it as a file on a disk. However, you are required to 
specify a filename and directory path, using a file 
selection dialog box very similar to the one shown in 
Section 4.3.5. You may specify .SPR, .CSV, or .TSV file 
format (Section 4.2). After saving, the status box in the 
top bar of the window displays “Saved” until changed. 
The newly specified filename and directory path appear in 
the window title bar. Now if you choose the Save 
command, this spreadsheet will be saved to the new 
filename and path. 
 
4.3.8 “Print” 
 This command sends the active spreadsheet to the 
printer which is presently selected as the default printer 
for Windows applications. A Print Spreadsheet window as 
shown below appears. You may choose to print the entire 
spreadsheet, a group of lines or columns you have selected 
by clicking and dragging before choosing this command, 
or a range of pages. You may also choose whether or not 
to include row headers, column headers, and grid lines. 
Click the Begin button to start printing. The Save button 
saves the choices you have made in the Print Spreadsheet 
window, offering them as defaults the next time you use 
the Print command. 
 

Print Spreadsheet

Print Amount

All

Selected Page Range
1

2

Start

End

Print Options
x Col Headersx Row Headers x Grid Lines

BEGIN SAVE CANCEL
 

 
 Q-Tracker does not provide an opportunity to 
change the default printer selection and setup. You must 
do that before choosing this command. Use Windows 
tools such as the Options menu in the Print Manager 
window, or the Printers window in the Control Panel. 
 
 Depending on the options you chose, the printed 
spreadsheet can look almost exactly like what you 
selected in the spreadsheet window, except that it is 
automatically broken up into sequential pages numbered 
at the bottom. If you use a color printer, it will attempt to  
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reproduce the colors on your screen, which have been 
selected with the Options menu. If your graphic printer is 
not capable of printing the font seen in the display, it will 
usually substitute a default font such as Courier, which 
resembles typewriter print. 
 
4.3.9 “Exit Spreadsheet” 
 This command is one way to get out of spreadsheet 
mode and return to opening mode. Another way is to 
double-click on the control-menu box at the upper left 
corner of the last remaining spreadsheet window, or pull 
down the control menu from that box and choose Close. 
 
 If you have created or loaded a spreadsheet in the 
spreadsheet window since the last time you closed it, and 
you haven’t saved it, a Spreadsheet Unload dialog box 
shown below appears. This happens even if you have 
cleared the window. The purpose is to make sure you 
don’t forget to save changes you have made in an existing 
spreadsheet that was previously saved and loaded again. 
 
 

Spreadsheet Unload

Spreadsheet1 has changed
Do you want to save the changes

Yes No Cancel
 

 
 
4.4 The Edit Menu 
 
4.4.1 “Cut”, and Selecting Cells 
 This command works essentially the same in 
displayed Q-Tracker spreadsheets as in other Microsoft 
Windows applications, but only on cells. A cell is a place 
for a number in the array of rows and columns, as shown 
in Figure 4-2. Click the cursor on a cell to select that cell, 
in Figure 4-2. Click the cursor on a cell to select that cell, 
denoted by a heavy rectangular border. Drag the cursor up 
or down and right or left to select a group of cells as 
shown below. The cell first selected keeps the rectangular 
outline, and the rest are shown with colors changed (white 
on black in this case). 
 

 
 
 
 
 
 

 Instead of selecting a cell, you can select an entire 
column by clicking on the header (label) at the top of that 
column. Drag the cursor left or right to select a group of 
columns as shown below: 
 
 
 

 
 
 
 
 Similarly, you can select an entire row by clicking 
on the header (row number) at the left end of that row. 
Drag the cursor up or down to select a group of rows as 
shown below: 
 
 
 

 
 
 
 
 When you have selected a cell, or group of cells, 
choose the Cut command. The selected cells are cleared, 
leaving them blank. The contents of the cut cells are 
placed on a special Q-Tracker spreadsheet clipboard for 
possible pasting later. This is not the Microsoft Windows 
clipboard, although it operates in a very similar manner. 
You cannot exchange data among those three separate 
clipboards. Any column headers that may be included 
with the selected group of cells are not cut from the 
spreadsheet, but they are copied to the spreadsheet 
clipboard. Row headers are neither cut nor copied. 
 
4.4.2 “Copy” 
 Like the Cut command in the preceding section, the 
Copy command works essentially the same in displayed 
Q-Tracker spreadsheets as in other Microsoft Windows 
applications, but only on cells. The cell, or cells, you have 
selected, as explained above (including column headers, if 
any), are copied to the spreadsheet clipboard (see 
preceding section) without being erased from the 
spreadsheet. 
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4.4.3 “Paste” 
 Like the preceding two commands, this one is 
much the same as the corresponding command in other 
Microsoft Windows applications operating only on cells 
(and column headers to a certain extent). Whatever has 
been copied to the spreadsheet clipboard (Section 4.4.1) 
with a Cut or Copy command is pasted into the displayed 
spreadsheet at the location you have selected with the 
cursor. The newly pasted cells overwrite and replace 
existing cells. Generally, for the command to work 
properly, you should first highlight a block running at 
least as many cells horizontally and vertically as the block 
that has been cut or copied. 
 
 You can paste cells that have been cut or copied 
from an entirely different spreadsheet—even an entire 
spreadsheet. This is a useful way to combine multiple 
flow data files into one spreadsheet. It is even possible to 
paste a group of lines from a spreadsheet for one site into 
a spreadsheet for another site. However, be careful in 
copying and pasting data from one spreadsheet to another. 
For instance, make sure the measuring units are the same 
in both spreadsheets, and that the rows are in proper order 
as to date and time. If there are inconsistencies in the 
composite result, Q-Tracker will not be able to make 
graphs from the spreadsheet. 
 
 When pasting, it is best to keep using the first four 
or five columns for their original purposes when a flow 
data file was opened in the spreadsheet. That is, keep 
using Column A for the date and time, Column B for 
level, Column C for velocity, Column D for volumetric 
flow rate, and Column E for rainfall (if selected in setup). 
 
 
 

 

 

Table 4-2.  Volumetric Flow Calculations Used by Q-Tracker (Section 4.4.7) 
 
Method Specified in Setup Data  =  flow (level, velocity) 
 
Circular Velocity times Area  =  circ_vxa (level, velocity, pipe id, silt depth) 
 
Circular Mannings  =  circ_mannings (level, pipe id, silt depth, slope, roughness) 
 
 
 
Be sure to include the underline character _ where specified in a function name. 
 
For each variable listed in parentheses, substitute either a numerical value or a column number followed by the 
pound sign, such as b# for the value in Column B on the same line of the spreadsheet. 

 
 
 
Furthermore, within a group of rows, keep using Columns 
B, C, and D for one site (the same Q-Tracker). 
 
 Once you have copied and pasted a calculated 
column, the calculation formula remains in the new 
column even if you clear or overwrite the data there. This 
applies both to the volumetric flow column and 
calculations you specify (Section 4.4.7). The automatic 
calculation will be triggered by certain actions such as 
switching back and forth between modes. 
 
4.4.4 “Clear Data” 
 This command erases the contents of all cells in the 
active spreadsheet window. Row and column headers 
remain as before. So do the formulas for calculated 
columns (Section 4.4.7). Averaging period, fonts, column 
width, and colors remain as previously selected for the 
spreadsheet window. 
 
4.4.5 “Clear All” 
 This command erases nearly everything in the 
spreadsheet window, including column headers as well as 
formulas for calculated columns (Section 4.4.7). 
Averaging period, fonts, column width, and colors remain 
as previously selected for the spreadsheet window. 
 
4.4.6 Changing Cell Values and Column Headers 
 A. Changing a cell value: The recommended 

method is to use the status box. Select the cell 
you want to change, and its numerical value is 
repeated inn the status box. Click there to get a 
cursor, and make whatever changes you want. 
Pressing the Enter key puts the new value into  



effect in the selected cell. If that column is used 
in calculating another column, the calculated 
column’s value on that line is automatically 
updated to reflect the change you made. For 
instance, changing the level value also changes 
the volumetric flow value in that line. If the cell 
was a calculated one (Section 4.4.7), the new 
number takes the place of the formula for this 
cell, and it will no longer be a calculated cell. 

 
 B. Changing a column header:  Select a whole 

column by clicking on its header, and the header 
is repeated in the status box. Click in the status 
box and make whatever changes you want. 
Pressing the Enter key puts the new header into 
effect for the selected column. 

 
4.4.7 Automatic Calculations for Selected Cells 
 The name “spreadsheet” becomes a reality when 
you use it to make automatic calculations among columns. 
Q-Tracker can do that within a given row, meaning a 
given measurement time and date. In other words, you can 
put in an algebraic equation for calculating cells in a given 
column from cells in other columns in the same rows. 
Actually, what you put in is the right side of an equation, 
more properly called a formula. The formula can include 
functions predefined within Q-Tracker for flow 
calculations such as Mannings and rectangular weirs. You 
can use different definitions for different rows within a 
column—perhaps normal velocity-times-area for flow in 
certain time periods and Mannings for other periods. 
 
 The following is the general procedure for putting 
in a formula for a group of cells within a column. This 
will typically be an empty column, but you can overwrite 
cells in a column. 
 
 A. Select (click on) one of the cells to which the 

formula will apply. A heavy border around the 
cell shows it has been selected. 

 B. Type in the formula, starting with an Equal Sign 
(=). If this is already a calculated column, the 
formula presently in effect will appear in the cell 
and the status box; you can overwrite it. Your 
formula will probably be longer than the cell, but 
that’s okay; the cell acts as an automatically 
moving window on the formula. Use 
conventional algebraic notation, with an asterisk 
(*) for multiplication, slash (/) for division, plus 
sign (+) for addition, and hyphen (-) for 
subtraction. Use parentheses and nests of 
parentheses for grouping. For cell values from 
other columns, use the column header letter 
followed by the pound sign, such as b# for level 
and c# for velocity. For predefined flow 
functions, see Table 5-2. For example, suppose 
you want Column G to be the sum of Column D 
and Column F. Then in a selected cell in Column 
G, you would type =d#+f#. 

 

 C. When you have typed in your formula, press the 
Enter key. The formula disappears, and the 
calculated value for that cell appears in the cell 
and in the status box. 

 D. With the same cell still selected, press the Equal 
Sign key again (=). The formula appears again in 
the cell, and this time in the status box also. 

 E. In the Edit Menu, choose the Copy command. 
This copies the formula from the status box to the 
Q-Tracker clipboard. 

 F. Select the cell or group of cells to which you 
want to apply the new formula. Then in the Edit 
menu, choose the Paste command. It is as though 
you had typed the same formula in all the 
selected cells as in the first one. The resulting 
calculated values appear in all the selected cells. 

 
 When you wish to find out whether the value in a 
given cell has been automatically calculated, select that 
cell and press the Equals Sign key. If a formula is in effect 
for that cell, it appears in the cell and in the status box. At 
that point, you can change the formula for that cell and put 
it into effect with the Enter key. 
 
 The calculation formula remains in effect for the 
column, even if you use the Cut or Clear Data commands. 
It can be cleared only by the Clear All command, by 
replacement of individual cell values (Section 4.4.6-A), or 
by repeating the procedure above to replace the formula 
with one consisting only of the Equal sign. 
 
4.5 The Options Menu 
 
4.5.1 “Averaging” 
 Use this command to select the type of time 
averaging which will be applied the next time you open a 
flow data file into the presently selected spreadsheet 
window. The averaging presently in effect is indicated by 
a check mark as shown below. To make another choice, 
click on it. 
 
 

Options

Fonts
Column Width
Colors

Averaging None
Hourly
Daily

  
 
 “None” means every measurement is inserted as a 
separate row (line) of data. Hourly averaging produces the 
arithmetic mean of all measurements within each clock 
hour, for a given column of the spreadsheet. For example, 
the resulting average row labeled 15:00 contains averages 
of all measurements made between 3:00 p.m. and 4:00 
p.m. Similarly, daily averaging produces the arithmetic 
mean of all measurements made during the designated 
day, beginning and ending at midnight. No weighting of  
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individual measurements is required in computing the 
averages, because the interval between measurements is 
constant. 
 
 The averaging period you select will remain in 
effect for the spreadsheet window which is presently 
active until it is changed by the Averaging command or by 
loading a saved >SPR spreadsheet having another 
averaging period. 
 
4.5.2 “Fonts” 
 This command calls up the Font Selection dialog 
box shown below. The type font presently selected for the 
active spreadsheet window is highlighted. The factory 
default font is highlighted in the example below: MS Sans 
Serif Regular 8 point. All fonts installed in your Microsoft 
Windows configuration are available to Q-Tracker. 
 
 
 

 
 
 
 
 You may choose another font, and it will be applied 
to the presently active spreadsheet window. It will remain 
in effect for that window until changed by the Fonts 
command or by loading a saved. SPR spreadsheet having 
a different font. 
 
4.5.3 “Column Width” 
 This command calls up the Column Width 
Selection box shown in the following column. In the 
Present Column box, select the column whose width you 
want to change. Columns are identified by number instead 
of letter: 1 means A, 2 means B, etc. The present width of 
that column is shown in the Column Width box, in units 
of 1/12 inch when printed. In other words, a column 12 
units wide will be one inch wide when printed. Enter the 
width you desire in the New Width box. To put your 
selection into effect, click on the Save button. To change 
the width of another column, repeat this process. 
 
 
 
 
 
 

  

1
2
3
4
5
6
7
8
9
10

A B C D
No Avg

Spreadsheet1

1 14 14
Present Column Column Width New Width

SAVE CANCEL

 
 
4.5.4 “Colors” 
 This command pulls down another menu from 
which to choose the active spreadsheet’s forecolor or 
backcolor for review and changing if desired. Forecolor 
means text, and backcolor means background. 
 

Options

Averaging
Fonts
Column Width
Colors

Backcolor
Forecolor

 
 
 In either case, a Color window appears. You can 
choose one of 48 predefined basic colors or one of 16 
custom colors which you can create. The custom color 
boxes initially contain factory default colors consisting of 
shades of gray. To create a custom color of your own, 
click on the “Define Custom Colors...” button near the 
bottom of the Color window. The window extends to 
display tools for defining color. 
 
 Select one of the 16 custom color boxes to be 
changed to the desired color. Then manipulate the color 
tools to get the desired color in the sample box labeled 
Color/Solid. The left side of this box shows the actual 
color as nearly as your computer can approximate it. The 
right side shows the nearest solid, unblended color. When 
you have finished defining a custom color with these 
tools, click on the “Add to Custom Colors” button, and the 
custom color box you previously selected changes to the 
newly defined color. Then click OK, and the selected 
color (one of the 48 basic colors, or one of the 16 custom 
colors) is applied to the forecolor or backcolor for the 
active spreadsheet. The spreadsheet window will keep the 
selected colors, even to later Q-Tracker sessions, until 
changed by the Colors command or by loading a saved 
.SPR spreadsheet having different colors. 
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4.6 The Graph Menu and Graph Icon 
 This menu consists of one command, called Graph 
Selected Data. It puts Q-Tracker into graph mode. The 
menu bar changes from the spreadsheet menus (Figure 4-
1) to the graph menus (Figure 5-1). If one or more graph 
windows are already open, the most recently selected one 
is activated. If there is no graph window already open, one 
is opened. If cells in one or more columns of the active 
spreadsheet are highlighted when this command is chosen, 
a graph is created in the most recently selected graph 
window (Section 2.6). For further operations from that 
point, see Section 5. 
 
 
 

 
 
 
 The Graph icon in the tool bar (Figure 3-1) has the 
same effect as the Graph Selected Data command. In 
report mode, the Graph icon has the same effect. If some 
cells are highlighted in a spreadsheet, even though that 
spreadsheet window is not presently active, a graph is 
created. In graph mode, however, the Graph icon has no 
effect. 
 
4.7 The Window Menu 
 Like the Window menu at each of the other Q-
Tracker menu bars, this is a common standard feature for 
Microsoft Windows applications. The commands in the 
menu are familiar ones for Windows users. They are 
briefly explained in Table 4-1. 
 

 



5.0  Graphs
 

 
 

 
 
 
 
 
 

Window

Cascade
Tile
Arrange Icons

1 Graph1
2 Spreadsheet1
3 Graph2

ToolbarLine
Log/Line
Area
3D Area
Scatter
2D Bar
3D Bar
Tape

TypeFile
New Graph Picture
Save Graph Picture
Load Graph Picture
Unload Graph Picture

Print Graph

Exit Graph

Options

Color
Fonts
Labels
Grids

X axis Tics
X axis position
Y axis position

Statistics
Curve Fit

View Graph Picture
View Graph

Control Panel              F4

View

None

X and Y
X only
Y only

X axis Time only
X axis Date only

X axis Date and Time

X axis T ime only

X axis Date only

X axis Date and Time

None
Mean
Min Max
Mean and Min Max
Std Dev
Std Dev and Mean
Std Dev and Min Max
Std Dev and Min Max and Mean
Best Fit
Best Fit and Mean
Best Fit and Min Max
Best Fit and Min Max and Mean
Best Fit and Std Dev
Best Fit and Std Dev and Mean
Best Fit and Std Dev and Min Max
All

Curve fit enabled

Curve only displayed
Curve and symbols displayed

None

Horizontial
Vertical
Vertical and Horizontial

Bottom
Top

Default

Right
Left

Default

Day
Hour

Minute

 
 
 

FIGURE 5-1 
The graph menu bar appears when a graph window is active. Menus pulled down from the bar are shown. 
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TABLE 5-1.  Functions of Items in the Graph Menus 
 
Menu Item Section Function 
 
File New Graph .......................  5.3.1..Open another graph window 
  Save Graph Picture ..........  5.3.2..Save active graph as a .BMP (bit-mapped) file 
  Load Graph Picture ..........  5.3.3..Display a stored .BMP image file in the active window 
  Unload Graph Picture ......  5.3.4..Remove a previously loaded .BMP image file in the active window 
  Print Graph.......................  5.3.5..Print the active graph window 
  Exit Graph........................  5.3.6..Return to opening mode 
View View Graph Picture..........  5.4.1..Enable or disable display of a .BMP image loaded into the active window 
  View Graph......................  5.4.2..Enable or disable display of a Q-Tracker graph in the active window 
  Control Panel ...................  5.4.3..Select plotted colors, y-axis scale, and captions, and read graph points 
Type Type .................................  5.5.....Select type of plot: line, log/line, area, 3D area, scatter, 2D bar, 3D bar, tape 
Options Statistics ...........................  5.6.1..Select type of statistical analysis for the active graph 
  Curve Fit ..........................  5.6.2..For scatter plots, enable or disable curve-fitting & display of curve and points 
  Color ................................  5.6.3..Choose background and foreground (axes & captions) colors for active graph 
  Fonts.................................  5.6.4..Choose font (type style and size) for the active graph 
  Labels...............................  5.6.5..Select numeric labels for x and y axes 
  Grids.................................  5.6.6..Turn grid lines on and off for x and y axes 
  X Axis Ticks ....................  5.6.7..Choose x-axis ticks every minute, hour, or day 
  X Axis Position ................  5.6.8..Choose top or bottom location for x axis 
  Y Axis Position ................  5.6.9..Choose left or right location of y axis 
Window Toolbar.............................  5.7.....Activate or deactivate the icon tool bar 
  Clipboard..........................  5.7.....Activate the Microsoft Windows clipboard viewer 
  Cascade ............................  5.7.....Arrange open windows in cascade format as other Windows applications 
  Tile ...................................  5.7.....Arrange open windows in tile format as in other Windows applications 
  Arrange Icons...................  5.7.....Automatically arrange visible Windows icons 
  List of Existing Windows  5.7.....Activate desired window as though you had clicked on it 
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5.1 Introduction 
 This Section 5 of the manual provides detailed 
explanations of Q-Tracker functions available through the 
graph menu bar. The other three sets of menus (opening, 
spreadsheet, and report menu bars) are explained in 
Sections 3, 4, and 6. Most of the Graph menu functions 
pertain to creating, modifying, saving, retrieving, and 
printing graphs containing flow data from Q-Tracker 
monitors. 
 
 Refer to Section 2.2 for an introduction to the menu 

structure by which Q-Tracker is used. 
 Refer to Section 2.6 for an introduction to Q-Tracker 

graphs. 
 Refer to Figure 5-1 and Table 5-1 for an overview of 

graph menus. 
 Refer to Figure 5-2 for an illustration of features 

discussed in this Section 5. 
 
5.2 General Facts About Graph Mode 
 
5.2.1 Generating Graphs 
 For basic concepts, see Section 2.6. To generate a 
graph, select the desired cells in a spreadsheet and choose  
 
 

  
 
the Graph icon. The Graph icon is equivalent to the 
“Graph Selected Data” command in the Graph menu at the 
Spreadsheet menu bar. Loading a previously generated 
and saved graph is a different operation, described in 
Section 5.3.3. 
 
 You don’t have to be in spreadsheet mode when 
you choose the Graph icon. However, a spreadsheet must 
be open, and two or more cells must be selected at the 
moment. You may select cells in any column other than 
Column A, the Date/Time column. You must select at 
least two rows in the spreadsheet. 
 
 The selected cells may be one or more entire 
columns, or they may be a group of cells comprising part 
of one or more columns. Each column (whole or part) 
gives rise to a separate plot in the graph. Since multiple 
columns can be selected only if they are all adjacent to 
one another, you cannot graph Columns B and D together 
without also graphing Column C. 
 
 If a graph window is not already open when you 
choose the Graph icon, Graph Window Number 1 will 
appear. If one graph window is already open, the graph 
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FIGURE 5-2 
Features of a typical Q-Tracker graph 

 
 
 
will appear in it. If more than one graph window is 
already open, the new graph will go in the one that is 
active, or (if not in graph mode) that was most recently  
active. As soon as the graph is generated, the 
corresponding spreadsheet cells are no longer selected. 
 
 You can have as many as five plots (five 
spreadsheet columns) in a single graph. The minimum 
number of spreadsheet lines that can be included varies 
according to the number of plots. 
 
 To read a plot with perfect accuracy, click on one 
of the data points. The X and Y value and point number 
appear in the information bar immediately below the 
uppermost window title bar. (See Figure 5-2.) Point 
numbers for each plot do not correspond with line 
numbers in the spreadsheet. They begin with 1 at the far 
left side of the  
 
 

 
 
graph. This point reading feature is not available in 
Log/Line, Area, or 3D Area type graphs. 
 
5.2.2 Graph Characteristics 
 As seen in Figure 5-2, the main title of a newly 
generated graph automatically consists of the study name 
and site ID number associated with the source 
spreadsheet. The left title, for the Y axis, is blank. Other 
characteristics (bottom title, plot type, colors, fonts, etc.) 
are the same as when that graph window was last used. 
You can change all these characteristics with the Control 
Panel command and the Type and Options menus. All 
characteristics except the main title and left title carry over 
to the next time this graph window is used. 
 
5.2.3 Distorting Image Proportions 
 The horizontal and vertical proportions of a graph 
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and a loaded image (Section 5.3.3) are automatically 
adjusted to the shape of the window. If the graph window 
is maximized, of course, its shape is determined by that of 
the monitor screen. When the Window is in its normal 
“restored” condition, you can change its shape and size as 
in any other Microsoft Windows application. This is done 
by dragging a border or corner with the cursor. In this 
way, you can make a graph or loaded image tall and slim 
or short and wide. 
 
 The type (letters and numbers) in a generated  
graph is never distorted, but its size changes to fit the 
graph. However, the type in a saved and loaded graph 
(Section 5.3.3) does get distorted along with the graph. 
 
 If you save or print the window (Sections 5.3.2 and 
5.3.5), the saved or printed image has the shape you see 
on your screen, however distorted it may be. As a result, 
for instance, if you save a generated graph while the 
window is short and wide, and if you then load the saved 
file in a more normally-shaped window, the image will be 
stretched vertically. 
 
5.2.4 Generating More Than One Graph 
 You can display more than one generated graph at 
the same time in different windows. When you want an 
additional graph window, use the New Graph command 
(Section 5.3.1). To activate a graph or spreadsheet 
window you need, you may use cascade or tile 
arrangement in the Window menu, and simply click in the 
desired window. Or, you may choose the desired window 
from the list in the Window menu. Select the spreadsheet 
cells you want to graph next, activate the graph window 
you want to see, and click the Graph icon. 
 
5.2.5 Suggestions For Using Graph Mode 
 There are limits to the amount of data that can be 
presented in one graph and in one plot. Plotting every 
measurement without averaging can be useful for 
checking the amount of scatter and related statistical 
purposes. However, many days of non-averaged data will 
overload the program’s graph capabilities. For graphing 
long periods, use hourly or daily averaging (Options menu 
in Spreadsheet mode, Section 4.5.1). 
 
 To find the presentation that provides the most 
meaningful view of the data, experiment with various 
combinations of averaging periods and graph type (Type 
menu). For instance, a logarithmic graph can be useful in 
presenting two or more plots whose average values differ 
by factors greater than about five. 
 
5.3 The File Menu 
 
5.3.1 “New Graph” 
 This command opens another graph window. The  
 
 
 

 
new window is assigned the lowest available number. For 
example, if you already have Graph 1 and Graph 4 open 
and no other, the New Graph command brings up Graph 
2. The newly opened graph window is blank. Graphs 
generated from spreadsheets in this window will retain the 
same menu selections (Control Panel, Type, and Options) 
that were in effect the last time this window was closed in 
the current Q-Tracker session or a previous session. The 
number of graph windows allowable depends on the 
amount of computer memory available to the Q-Tracker 
program. 
 
5.3.2 “Save Graph Picture” 
 This command saves the image displayed in e 
active graph window, storing it as a bit-mapped .BMP file 
on a disk. You are required to specify a filename and 

irectory path, using a file selection dialog box. d 
 

graph1.bmp
inigdv1l.bmp
inola.bmp
inola1.bmp
pump.bmap
secln-0.3.bmp

Save File as Type: Drives:
c:BMP (*.BMP')

BMP (*.BMP')

c:\
qtracker
inola

Graph Picture Save

File Name: Directories:

Read Only

c:\qtracker\inola\inola.bmp c:\qtracker\inola
OK

Cancel

   
 After saving, what is displayed in the window is 
still the same image as before, not the saved image. If you 
started with a generated graph, you still have the 
generated graph, not the bit-mapped image that was saved 
as a file. 
 
 If the active window is displaying both a generated 
graph and a loaded picture (following section) 
superimposed on each other, the entire composite image 
will be saved. However, the quality of the previously 
saved portion of the combined image may be noticeably 
degraded. The shape of the saved image in terms of 
horizontal and vertical proportions is what you see on the 
screen (Section 5.2.3). 
 
5.3.3 “Load Graph Picture” 
 This command retrieves a bit-mapped .BMP image 
from storage and displays it in the active graph window. 
The image is usually a Q-Tracker graph generated from a 
spreadsheet, which has been stored with the Save Graph 
Picture command. However, it may be any compatible 
.BMP image file produced by another program—perhaps 
a scanned photograph of a flow study site. The image file 
is selected with a Graph Picture Load dialog box which 
resembles the Graph Picture Save box shown in the 
preceding section. After the image is loaded into an empty  
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window, the file name and directory path of the image file 
is displayed in the information bar in the place of the point 
value readout. 
 
 A graph window can simultaneously contain one 
generated graph and one bit-mapped image. The generated 
graph is produced by Q-Tracker from a spreadsheet, and 
the image is loaded from a .BMP file. You can display 
either or both of these two objects, using the View Graph 
Picture and View Graph commands in the View menu. 
(See Sections 5.4.1 and 5.4.2) The information bar 
displays the point value readout for the generated graph 
instead of the filename and path for the loaded image. 
This happens even if only the loaded image is displayed at 
the moment. Even when not displayed, both objects are 
still in the window and can be turned on or off. If the 
generated graph is turned off, you can still get point value 
readings from it by searching for plot points with the 
cursor. 
 
 If you load an image into a window that already has 
a loaded image, the new image overwrites and replaces 
the old one. 
 
 Control Panel, Type, and Options do not work on a 
loaded graph image. A loaded Q-Tracker graph looks 
almost exactly like the generated original, but it is only an 
image, not the real thing. If the active graph window does 
not contain a generated graph, the menu selections above 
are not available; neither is the Copy to Clipboard 
command. 
 
 Q-Tracker automatically scales (adjusts the size of) 
the entire loaded image to fit the active window in both 
the horizontal and vertical directions. If the proportions of 
the original image are different from those of the window, 
the image will be uniformly distorted by stretching or 
compressing. (See Section 5.2.3.) Distortion is especially 
noticeable in the case of a scanned photograph image. 
You may restore the original shape of the image by 
changing the shape of the window as in any Microsoft 
Windows application. (Click and drag on an edge or 
corner of the window.) 
 
 You can use the Load Graph Picture command to 
insert an illustration into a suitable blank area of a graph, 
such as a corner. For instance, you may want to 
incorporate your company logotype. To do so, you must 
first prepare a .BMP image having the same proportions 
as the graph, using a suitable graphics program. This 
image should be featureless (blank) except for the logo, to 
avoid interfering with the visibility of the graph. Put the 
logo at the position in the image where you want it to 
appear in the graph. 
 
 
 
 

 
 
 
5.3.4 “Unload Graph Picture” 
 If the active graph window contains a loaded 
picture (see preceding section), this command removes it. 
 
5.3.5 “Print Graph” 
 This command sends the contents of the active 
graph window to the printer which is presently selected as 
the default printer for Windows applications. Whatever 
you see in the window is printed. This may include both a 
generated spreadsheet (Section 5.2.1) and a loaded picture 
(Section 5.3.3) as a superimposed composite. The shape 
of the printed image in terms of horizontal and vertical 
proportions is what you see on the screen (Section 5.2.3). 
Printing takes place immediately, signified by the 
momentary Graphics Server window. 
 
 Q-Tracker does not provide an opportunity to 
change the default printer selection and setup. You must 
do that before choosing this command. Use Microsoft 
Windows tools such as the Options menu in the Print 
Manager window, or the Printers window in the Control 
Panel. 
 
 The resolution or smoothness of the printed image 
of a loaded picture, whether it is a saved Q-Tracker graph 
or other image, will duplicate that seen on the monitor 
screen. Curved and diagonal lines and edges will probably 
have a noticeable stair step appearance. However, a 
generated graph prints with much high resolution, 
looking as smooth and sharp as the printer can make it. 
 
 If you use a color printer, it will attempt to 
reproduce the colors on your screen, which have been 
selected with the Control Panel (Section 5.4.4) and the 
Options menu (Section 5.6). If your graphic printer is not 
capable of printing the font seen in the display, it will 
usually substitute a default font such as Courier, which 
resembles typewriter print. 
 
5.3.6 “Exit Graph” 
 This command is one way to get out of graph mode 
and return to opening mode. Another way is to double-
click on the control menu box at the upper left corner of 
the last remaining graph window, or pull down the control 
menu from that box and choose Close. 
 
 If you have made any changes in a generated graph 
or loaded image, but have not saved the result (Section 
5.3.2), a Graph Unload dialog box shown on the following 
page appears. This happens even if the only change was to 
reshape the window, and even if you have cleared the 
window. The purpose is to make sure you don’t forget to 
save any changes that you may want to keep. 
 
 If you click the Yes button, it is as though you had 
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The Graph Control Panel 
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chosen the Save Graph Picture command (Section 5.3.2). 
You are required to select, or key in, a filename and path 
in a Graph Picture Save dialog box. This reminder 
procedure is repeated for all graph windows having 
changes that have not yet been saved. Finally, Q-Tracker 
returns to the Opening mode. 
 
5.4 The View Menu 
 
5.4.1 “View Graph Picture” 
 This command is available only if the active 
window has a loaded image (Section 5.3.3). If there is no 
such image, the command in the menu is displayed in faint 
gray type. A check mark by this command indicates the 
loaded image is presently visible. Choosing this command 
turns the image and the check mark on or off. Whenever 
you load an image, it is visible until you turn it off. 
 
5.4.2 “View Graph” 
 This command is available only if the active 
window has a generated graph (Section 5.2.1). If there is 
no such graph, the command in the menu is displayed in 
faint gray type. A check mark by this command indicates 
the graph is presently visible. Choosing this command 
turns the graph and the check mark on or off. Whenever 
you generate a graph, it is visible until you turn it off. 
 
 

 
 
 
5.4.3 “Control Panel” 
 This command is available only when you have a 
generated graph in the active window. It calls up the graph 
control panel shown in Figure 5.3. 
 
 In the top part of the Data box in the control panel, 
you may select the color and texture of each plot. In the 
Title window, click the up or down arrow to select the 
plot you wish to design, identified by its header in the 
spreadsheet. In the color window, click the up or down 
arrow to select a color for that plot. Next to the Line Type 
window, select either a “thick” line (meaning a solid line) 
or a “patterned” line. Then in the Line Type window, click 
the Up or Down arrow to select one of four line thickness’ 
or line patterns. A short sample of the selected pattern is 
shown in the window. Patterns of dots and dashes make 
multiple plots more readily distinguishable from one 
another when printed in black and white. If the graph has 
more than one plot, select another and repeat this process. 
 
 In the bottom part of the Data box, you will find a 
readout of data points in the plot selected above. This 
method is more closely controlled than clicking on a plot 
in the graph window and reading values in the information 
bar. Furthermore, you can change the value of the selected 
point by keying in whatever you want. It is a way to edit 
in graph mode instead of editing the spreadsheet. The 
spreadsheet is not affected. 
 
 In the Y Axis box in the control panel, you can 
select either automatic or manual scaling of the vertical Y 
axis. (However, manual scaling is not available if you 
have chosen log/line presentation in the Type menu, 
Section 5.5.) For manual scaling, key in the values you 
want for the minimum (bottom end) and maximum (top 
end) of  
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the Y axis. Also use the up and down arrows to select the 
number of ticks you want along this axis. To get the right 
number of ticks, decide on the interval you want between 
ticks, and divide that into the difference between 
minimum and maximum values. For example, suppose the 
bottom value is 0.2, the top end reads 1.0, and you want a 
tick every  0.1 unit along the axis. Thus 1.0 minus 0.2 
equals 0.8, and dividing that by the interval of 0.1 gives 8 
ticks. 
 
 In the Titles box, there are windows for keying in 
the main graph title above, the bottom title for the 
horizontal X axis, and the left title for the vertical Y axis. 
(The left title remains at the left even if you choose the 
right side for the Y axis position in the Options menu, 
Section 5.6.9.) When the graph is first generated, the 
graph title is automatically the study name and site ID as 
shown in Figure 5-2. Furthermore, there is no left title, 
and the bottom title is whatever was in effect the last time 
this graph window was used. Each title can consist of as 
many as 40 characters. Type fonts and colors are selected 
in the Options menu (Section 5.6). To edit an existing 
bottom title, you must first delete the portion you want to 
change. 
 
 When you click on the Return button, any changes 
you have made are immediately put into effect in the 
active graph window. 
 
5.5 The Type Menu 
 In this menu, choose one of the eight listed types of 
graph presentation for the active window. The type which 
is presently in effect is identified by a check mark. 
 
 

Line
Log/Line
Area
3D Area
Scatter
2D Bar
3D Bar
Tape

Type

 
 
 
 
5.6 The Options Menu 
 
5.6.1 “Statistics” 
 This command calls up a menu which is available 
only when you have chosen the Line or Scatter 
presentation in the Type menu (Section 5.5). 
 
 You may choose one of these sixteen different 
combinations of the features listed. They are applied to the 
Y values of all the data points in each plot of the active 
graph. 
 
 

 
None
Mean
Min Max
Mean and Min Max
Std Dev
Std Dev and Mean
Std Dev and Min Max
Std Dev and Min Max and Mean
Best Fit
Best Fit and Mean
Best Fit and Min Max
Best Fit and Min Max and Mean
Best Fit and Std Dev
Best Fit and Std Dev and Mean
Best Fit and Std Dev and Min Max
All  

 
 A. Mean:  The arithmetic mean or average of all 

the points, shown as a horizontal line across the 
graph. 

 
 B. Minimum and Maximum:  The highest and 

lowest of all the points, shown as two horizontal 
lines across the graph. 

 
 C. Standard Deviation:  An indication of how widely 

the data points are scattered away from the mean. 
This is the square root of the arithmetic average of 
the squares of the deviations of all points from the 
mean. It is shown as two horizontal lines lying one 
standard deviation above and below the mean. 

 
 D. Best Fit:  A straight line, usually slanting, drawn 

so as to minimize the sum of the deviations of all 
the points from it. That is , the line comes as close 
as possible to as many points as possible. 

 
5.6.2 “Curve Fit” 
 This command calls up a menu which is available 
only when you have chosen the Scatter presentation in the 
Type menu (Section 5.5): 
 

Curve fit enabled

Curve only displayed
Curve and symbols displayed  

 
 If you enable curve-fitting (indicated by a check 
mark), Q-Tracker calculates a gently curved line which 
minimizes the sum of the deviations of all the points from 
it. (That is, the curve comes as close as possible to as 
many points as possible.) The menu allows you to display 
either the curve alone or both the curve and the scattered 
data points. A second check mark indicates the choice 
currently in effect. 
 
5.6.3 “Color” 
 This command calls up the graph color box. Use it  
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to choose the foreground color and the background color 
for the active graph. 
 
 The foreground color is applied to the axes, grids, 
ticks, axis labels, titles, and legends. The background is 
everything else, both inside and outside the actual graph 
or grid area. However, an additional background color is 
automatically created for 3D Area, 3D Bar, and Tape 
presentations. In these cases, the background within the 
grid is generally the complement of the selected 
background color. The complement of a color is its 
opposite on a color wheel. 
 
 Clicking on the “Save” button immediately puts 
your color selections into effect in the active graph. 
Clicking the “Exit” button cancels your changes and 
reverts to the colors you had before choosing this 
command. 
 
5.6.4 “Fonts” 
 This command calls up the Graph Fonts window 
shown below. Use it to choose type font characteristics for 
the active graph: 
 

Swiss +
Font Family

Underlined Bold Italic +
Font Style

Graph Fonts

+Graph Title
Graph Title
Bottom and Left Titles
X and Y Axis Labels
Graphed Data Legends
All text

Font Use

200.
% Font Size

SAVE
 

 
 Each of the four text items listed in the Font usage 
window is separately specified: main graph title, bottom 
and left titles, X and Y axis labels, and graphed data 
legends. See Figure 5-2 for the locations of these items. 
Titles are created with the Control Panel (Section 5.4.3), 
and labels are specified with the Labels command 
(Section 5.6.5). Legends are automatically generated from 
spreadsheet headers. 
 
 Three fonts provided with Q-Tracker are available 
in the Font Family window above: Swiss (Gothic or Sans-
Serif), Roman, and Modern (typewriter style). You may 
select various combinations of italic, bold, and underlined 
in the Font Style window. Q-Tracker automatically 
applies some interlocks and overrides to your choices of 
font size. For instance, the axis labels are not allowed to 
be much larger than the space between ticks. 
 
 Clicking on the “Save” button immediately puts 
your font selections into effect in the active graph. 
Clicking the “Cancel” button cancels your changes and 
reverts to the choices you had before. 
 

 
5.6.5 “Labels” 
 This command calls up a sequence of menus shown 
in Figure 5-1 and below. 
 

X and Y
X only
Y only

None

X axis Date and Time
X axis Time only
X axis Date only  

 
 
 First, you may choose whether you want number 
labels for the X axis, the Y axis, or both. Then if you have 
chosen X axis labels, you may choose what kind of labels 
you want there: time, date, or both. A check mark 
indicates the choice which is currently in effect. 
 
5.6.6 “Grids” 
 This command calls up the menu shown below. 
Use it to choose whether or not you want grid lines on the 
active graph, and if so, whether you want horizontal or 
vertical lines or both. A check mark indicates the choice 
which is currently in effect. 
 

None
Horizontial
Vertical
Vertical and Horizontial  

 
 
 There will generally be one grid line for each tick 
mark you have specified. X axis ticks are chosen with the 
“X Axis Ticks” command that follows this one in the 
Options menu. Y axis ticks are chosen in the Control 
Panel (Section 5.4.3). If you have chosen log/line 
presentation in the Type menu (Section 5.5), there will be 
one grid line for each decade (0.01, 0.1, 1.0, 10, etc.) and 
one for each tenth of a decade (2, 3, 4, 5, 6, 7, 8, 9, etc.). 
 
5.6.7 “X Axis Ticks” 
 This command calls up the menu shown below. 
 
 

Day

Minute
Hour

 
 
 
 Use this menu to choose the interval at which tick 
marks appear along the horizontal X axis in the active 
graph. A check mark indicates the choice which is 
currently in effect. 
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5.6.8 “X Axis Position” 
 This command calls up the menu shown below. 
Use it to choose whether you want the X axis ticks and 
number labels to be located at the top or at the bottom of 
the active graph. A check mark indicates the choice which 
is currently in effect: 
 
 

Bottom

Default
Top

  
 
 In most cases, the customary location is at the 
bottom. The 3D Area, 3D Bar, and Tape presentation 
types (Section 5.5) are designed for bottom location of the 
X axis. 
 
5.6.9 “Y Axis Position” 
 This command calls up the menu as shown in the 
next column. Use it to choose whether you want the Y 

axis ticks and number labels to be located at the left or at 
the right of the active graph. A check mark indicates the 
choice which is currently in effect. 
 
 

Right

Default
Left

 
 
 
 In most cases, the customary location is at the left. 
The 3 D Area, 3D Bar, and Tape presentation types 
(Section 5.5) are designed for left location of the X axis. 
 
5.7 The Window Menu 
 Like the Window menu at each of the other Q-
Tracker menu bars, this is a common standard feature for 
Microsoft Windows applications. The commands in the 
menu are familiar ones for Windows users. They are 
briefly explained in Table 5-1. 
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6.0  Preformatted Reports
 
 
 
 

Create Report . . .

View Saved Report . .
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Report Library

Report Options

Enable Disable

Data Filename
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Exit

Report Manager

0%

 
 
 

FIGURE 6-1. 
Report Manager Window 

 
 
 
 
6.1 Introduction 
 This Section 6 of the manual provides detailed 
explanations of Q-Tracker operations in the report mode 
(Section 2.2). The other three sets of menus (Opening, 
Spreadsheet, and Graph menu bars) are explained in 
Sections 3, 4, and 5 of the manual. To get into the report 
mode, see Section 3.6.2. 
 
 Whenever you want to display or print a flow data 
file, you first have to open it in either a report or a 
spreadsheet. Graphs are created only from spreadsheets, 
so a spreadsheet is often created merely as an intermediate 
step in generating a graph. 
 
 A report is similar to a spreadsheet in that both 
present Q-Tracker measurements from a flow data file. 
Both use tabular formats consisting of rows and columns, 
with each row representing a time of measurement. The 
difference is that a report has a summary for each day with 
minimum, maximum and average values for level, 
velocity and flow as well as the total flow. 
 
 Refer to Section 2.2 for an introduction to the menu 

structure by which Q-Tracker is used. 
 Refer to Section 2.4 for an introduction to preformatted 

reports. 
 
 

 
 
6.2 Report File Format 
 Q-Tracker converts a downloaded data file into a 
data base format. A new file is created with the same 
name as the raw data file except the extension identifier 
‘@’ for the raw data file name is 11209410.@07, the new 
data base file name will be 112094.d07. Reports are then 
generated from the data base. There are three standard 
types of reports: no average, hourly average, and daily 
average. Generated reports can be saved for future review 
in the Q-Tracker report format or can be saved in several 
different formats for exporting for use in other programs. 
This will be explained in more detail later in this section. 
 
 
6.3 The Report Manager 
 To enter into the report mode, click on the Report 
icon or in the Opening menus select the Data menu then 
Report. The Report Manager window will appear. 
 
 The Report Manager allows the selection of the 
type of report desired and selection of the data file for 
which a report is to be made. The Report Type needs to be 
selected before selecting a data file. 
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6.3.1 “Report Type” 
 The Report Type section of the Report Manager 
selects the type of report that is to be generated. There are 
five choices: No average; 15 Minute average; Hourly 
average; Daily average; Custom report. To make a 
selection click on he desired type of report. The circle will 
darken for the selected report. All of the report types give 
daily summaries of date and time of the minimums and 
maximums of level, velocity and flow and the average 
flow and daily total. 
 
 When Customer report is selected, the Report 
Library button will become active. Click on the Report 
Library and the Qtracker Report Directory window will 
open. There will be six report files listed in the file box; 
qt15min.rpt, qtrday,rpt, qtrdayg.rpt, qtrevr.rpt, 
qtrwkly.rpt, and qtrwklyg.rpt. The report files; 
qt15min.rpt (15 minute average), qtrday.rpt (hourly 
average), qtrevr.rpt (no average) and qtrwkly.rpt (daily 
average) are the standard reports listed in the Report Type 
box. The files qtrday.grpt and qtrwklyg.rpt are the custom 
reports presently available. These reports are the same as 
the standard reports except a graph of the flow data is 
added after the summary of each day. 
 
6.3.2 “Report Options” 
 This section of the Report Manager allows the user 
to write a script that selects specific records to be 
generated into a report from a file data base. For example, 
a specific time frame of a data file such as records 
between two dates, or only Saturdays and Sundays, or 
only records that have flow above a specific flow. The 
following are scripts that can be entered into the Report 
Options box: 
 
 ({data.date/time})>(date(yyyy,mm,dd)) and 

({data.date/time})<(date(yyyy,mm,dd)) 
 This script selects all records for a report 

between the first date and the second date. The 
date must be in the form as shown; year, month 
date (1994,06,07). If the date in the script had 
been 1994,05,30 and 1994,07,01, the report 
would be from June 1, 1994 to June 30, 1994. 

 
 ({data.date/time})>(date(yyyy,mm,dd)) 
 This script selects all records for a report after 

the date in the script. 
 
 dayofweek ({data.date/time})=1 
 This script selects records for every Sunday in 

the data file data base. To select more than one 
day, repeat the script again inserting ‘or’ 
between the two scripts. For example, to select 
Sundays and Saturdays the script would be: 

 dayofweek ({data.date/time})=1 or 
 dayofweek ({data.date/time})=7 
 
 
 

 
 
 ({data.flow})>2 
 This script selects all the records that have a 

flow value above 2. In this example the flow 
units are in MGD (determined by the setup file 
in the data file) so only the records with flow 
over 2 MGD will be in the report. Records can 
be selected based on level or velocity by 
substituting velocity or level for flow in the 
script. 

 
 The Report Options must be enabled to work. Click 
on the En able to activate the use of the script in the box. 
To deactivate the Report Options, click on Disable. The 
script in the box will be saved automatically when closing 
the Report Manager. 
 
6.3.3 “Data Filename Button” 
 After selecting the type of report desired, click on 
the Data Filename button. The Qtracker Datafiles window 
will appear, which is typical of Windows applications. 
The appropriate file type is already selected (extensions 
beginning with @). Select the desired data file from the 
appropriate subdirectory (study name) under the Qtracker 
directory. See Section 6.3.6, Report Window, for 
explanation of the report functions. 
 

  
 
6.3.4 “Create Report Button” 
 This button becomes active after a data file has 
been selected. This allows the user to change the type of 
report after a report has already been generated from a 
data file. 
 
6.3.5 “View Saved Report Button” 
 This button allows the user to recall a report 
previously saved. Click on the View Saved Report.. 
button and the Qtracker Saved Reports window opens. 
Select the desired report from the files listed in the file 
box. The report will be regenerated in the Report 
Window. See Section 6.3.6 for instructions on the Report 
Window. 
 
6.3.6 “Report Window” 
 After selecting the data file, the report window 
appears as shown in Figure 6-2. At the bottom right of the 
window the total number of records and the percent  
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FIGURE 6-2 

Example of Typical Report 
 
 
completion of the search will be shown. Once the search 
is complete the progress of the structuring of the report 
will be shown at the bottom left of the window as the 
pages are completed. There is a Cancel button at the 
bottom of the window that can be used to stop the data 
base search or structuring of the report. 
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 Once the report is complete the number of pages 
and page presently being displayed is shown at the bottom 
left of the report window. There are arrow buttons to the 
left and right of the number of pages. The first arrow 
button to the right, when clicked on, advances through the 
report one page at a time. The second arrow button to the 
right, when clicked on, advances to the end of the report. 
The first arrow button to the left, when clicked on, goes 
backwards through the report one page at a time. The 
second arrow button to the left, when clicked on, goes 
back to the beginning of the report. 
 
 There are four icon buttons at the bottom of the 
Report Window. The first icon on the left is the View 
icon, the second icon is the Print icon, the third icon is the 
Export icon and the fourth icon is the Email icon (which is 
not operational at this time). Click on these buttons to 
activate their function. 
 
 The View icon allows the zooming in and out of 
the report. Click on the View icon button and the view 
zooms out to show the complete page of the report. Click 
on the View icon button again and the view zooms in.  
 
 
 

 
Click on the View icon button again and the view goes 
back to the normal view. 
 
 The Print icon allows the printing of the report. Click 
on the Print icon button and the Print window will appear: 
 
The printer currently selected in the Windows Print 

Manager is shown. If the printer shown is not the desired 
printer, cancel the Print window and switch out of Q-
Tracker for Windows to the Program Manager and open 
the Print Manager. Select the desired printer and return to 
the Q-Tracker program. Select the Print icon again to open 
the Print window. There is a print range selection where 
all pages will be printed or only selected pages. If the 
desire is to print only a select number of pages click on 
Pages to activate the From and To boxes. The From box 
will be highlighted. Type the first page to be printed then 
press the Tab key, or click in the To box and type the last 
page to be printed. If more than one copy is desired, click 
in the Copies box and type the number of copies. Press the 
Enter key or click on the OK button to start the printing 
operation. 

 



 
 
 
 The export icon allows the saving of a report file. 
Click on the Export icon button and the Export window 
appears. There are several formats that the report can be 
converted into for use in other programs. Click on the 
down arrow next to Format box and the list of choices will  

 

 
 
 
appear. Select the desired format by clicking on it. Press 
the ENTER key, or click on the OK and the Choose 
Export File window appears. The File Name box will be 
highlighted. Type in the desired name for the file. The file 
will be saved under the qtracker directory unless the user 
chooses another directory in the Directories box. Press the 
Enter key or click on the OK button to complete the 
export. 

 

 
 To quit the report click on the Close button at the 
bottom of the Report window. To exit out of the Report 
Manager click on the Exit button. 
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WARRANTY 

 
Badger warrants meters and parts manufactured by it and supplied 
hereunder to be free from defects in materials and workmanship 
for a period of 18 months from date of shipment or 12 months 
from date of installation, whichever period shall be shorter. If 
within such period any meters or parts shall be proved to Seller’s 
satisfaction to be defective, such meters or parts shall be repaired 
or replaced at Seller’s option. Seller’s obligation hereunder shall 
be limited to such repair and replacement and shall be conditioned 
upon Seller’s receiving written notice of any alleged defect within 
10 days after its discovery and, at Seller’s obligation hereunder 
shall be limited to such repair and replacement and shall be 
conditioned upon Seller’s receiving written notice of any alleged 
defect within 10 days after its discovery and, at Seller’s option, 
return of such meters or parts f.o.b. to Seller’s factory. THE 
FOREGOING WARRANTY IS EXCLUSIVE AND IN LIEU OF 
ALL OTHER EXPRESS OR IMPLIED WARRANTIES 
WHATSOEVER IN-CLUDING BUT NOT LIMITED TO 
IMPLIED WARRANTIES (EXCEPT OF TITLE) OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. Badger shall not be liable for any defects attributable 
to acts or omissions of others after shipment, nor any 
consequential, incidental or contingent damage whatsoever. 
 
 
 

NUCLEAR DISCLAIMER 
 
Equipment sold by Badger Meter, Inc. is not intended for use in 
connection with any nuclear facility or activity unless covered by a 
specific quotation where the conditions of such usage will be 
detailed. If equipment is used in a nuclear facility or activity 
without a supporting quotation, Badger Meter disclaims all 
liability for any damage, injury or contamination, and the buyer 
shall indemnify and hold Badger Meter, its officers, agents, 
employees, successors, assigns and customers, whether direct or 
indirect, harmless from and against any and all losses, damages or 
expenses of whatever form or nature (including attorney’s fees and 
other costs of defending any action) which they, or any of them, 
may sustain or incur, whether as a result of breach of contract, 
warranty, tort (including negligence), strict liability or other 
theories of law, by reason of such use. 
 

 
Q-Tracker is a trademark of Badger Meter, Inc. 

 
Microsoft, MS, and MS-DOS are registered trademarks of Microsoft 

Corporation. Windows is a trademark of Microsoft Corporation. 
 
 

All rights reserved. All data subject to change without notice. 
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BadgerMeter,Inc. 
6116 E. 15Th Street, P O Box 581390 

Tulsa, Oklahoma  74158-1390 
(918) 836-8411  FAX: (918) 832-9962


